summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-25 15:49:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-25 16:00:33 +0100
commit2d0dc53cb0d0e4a9c4b19b362c48dcd34e842fa1 (patch)
tree906ab479dc268fb9e3ffbcd6a9a7e11e3b4a5f85 /app-misc/tmux/tmux-2.8-r2.ebuild
parentsys-libs/tevent: Added missing dev-libs/libbsd to RDEPEND. (diff)
downloadgentoo-2d0dc53cb0d0e4a9c4b19b362c48dcd34e842fa1.tar.gz
gentoo-2d0dc53cb0d0e4a9c4b19b362c48dcd34e842fa1.tar.bz2
gentoo-2d0dc53cb0d0e4a9c4b19b362c48dcd34e842fa1.zip
app-misc/tmux: Revbump using correct release tarball.
Closes: https://bugs.gentoo.org/681736 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc/tmux/tmux-2.8-r2.ebuild')
-rw-r--r--app-misc/tmux/tmux-2.8-r2.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-2.8-r2.ebuild b/app-misc/tmux/tmux-2.8-r2.ebuild
new file mode 100644
index 000000000000..851cb2d6a792
--- /dev/null
+++ b/app-misc/tmux/tmux-2.8-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="https://tmux.github.io/"
+SRC_URI="https://github.com/tmux/tmux/releases/download/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
+
+DEPEND="
+ dev-libs/libevent:0=
+ sys-libs/ncurses:0=
+ utempter? (
+ kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ )"
+
+BDEPEND="
+ virtual/pkgconfig"
+
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? ( app-vim/vim-tmux )"
+
+DOCS=( CHANGES README TODO )
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4-flags.patch
+
+ # upstream fixes (can be removed with next version bump)
+)
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ $(use_enable utempter)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ dodoc example_tmux.conf
+ docompress -x /usr/share/doc/${PF}/example_tmux.conf
+}
+
+pkg_postinst() {
+ if ! ver_test 1.9a -ge ${REPLACING_VERSIONS:-1.9a}; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}