summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-10 11:56:46 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-10 11:56:46 +0100
commit7c5a09de43d72b0398763fc04118064d06c3a293 (patch)
tree543bc05def14b34ef2de67cf28cb25682f301dd8 /app-misc/tmux/tmux-9999.ebuild
parentapp-misc/tmux: Drop versions vulnerable to 'Out of bounds heap read' (diff)
downloadgentoo-7c5a09de43d72b0398763fc04118064d06c3a293.tar.gz
gentoo-7c5a09de43d72b0398763fc04118064d06c3a293.tar.bz2
gentoo-7c5a09de43d72b0398763fc04118064d06c3a293.zip
app-misc/tmux: Ebuild style enhancements
* Add missing slot operators to ncurses dep * Use REPLACING_VERSIONS instad of has_version * Move user notice to pkg_postinst() Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild39
1 files changed, 28 insertions, 11 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index f809290ff99e..1e3c5867dabc 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,33 +1,36 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-AUTOTOOLS_AUTORECONF=true
-inherit autotools-utils git-r3 bash-completion-r1 flag-o-matic
+AUTOTOOLS_AUTORECONF=true
-EGIT_REPO_URI="https://github.com/tmux/tmux.git"
+inherit autotools-utils git-r3 bash-completion-r1 flag-o-matic versionator
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="http://tmux.github.io/"
SRC_URI=""
+EGIT_REPO_URI="https://github.com/tmux/tmux.git"
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
IUSE="debug selinux vim-syntax"
-COMMON_DEPEND="
+CDEPEND="
>=dev-libs/libevent-2.0.10
- sys-libs/ncurses"
-DEPEND="${COMMON_DEPEND}
+ sys-libs/ncurses:0="
+DEPEND="${CDEPEND}
virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( || (
- app-editors/vim
- app-editors/gvim ) )"
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )"
DOCS=( CHANGES FAQ README TODO )
@@ -69,3 +72,17 @@ src_install() {
doins "${FILESDIR}"/tmux.vim
fi
}
+
+pkg_postinst() {
+ if ! version_is_at_least 1.9a ${REPLACING_VERSIONS:-1.9a}; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}