summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-09-27 17:52:38 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-09-27 17:52:38 -0700
commit6c4bd52f95237c9ebfcc4b99346524dffbb716c5 (patch)
tree03b6d54dd8e34ff8586fa536f20ab1ed7a315d01 /app-misc/tmux
parentapp-admin/ansible: 2.5.10 bump (diff)
downloadgentoo-6c4bd52f95237c9ebfcc4b99346524dffbb716c5.tar.gz
gentoo-6c4bd52f95237c9ebfcc4b99346524dffbb716c5.tar.bz2
gentoo-6c4bd52f95237c9ebfcc4b99346524dffbb716c5.zip
app-misc/tmux: Version bump to 2.8
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/Manifest1
-rw-r--r--app-misc/tmux/tmux-2.8.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-misc/tmux/Manifest b/app-misc/tmux/Manifest
index 2871890799a7..1e01240cc5a1 100644
--- a/app-misc/tmux/Manifest
+++ b/app-misc/tmux/Manifest
@@ -1,4 +1,5 @@
DIST tmux-2.6.tar.gz 481000 BLAKE2B adbd276261f3f4be9d67c6c0fbad28a90eabbecfa68ebbc104fe56acaa9b7bd005060b854ce0a0e669fdf41dd058bfa8450a85a78f71f7248a44d25458f7d3bc SHA512 20a1ae8b8494c5b42757902322f3877731c2cc330c9c00f097a317785d25252b7ebaa8bbab9fc17843299e80cb2914aaac0a664715a85c50f7ea489d23753832
DIST tmux-2.7.tar.gz 487585 BLAKE2B 9c56da03bd12b358fcbed82def9680c34e1e485f906cf9b90a501e53b109c43d1ee843972d26e677de2c34830e599edee022dc1c17e1e5c935ed232caacb2b01 SHA512 7839ef748ea55df8c02c727047f65bd235b5e3b8ab23157246071e1b9954fa269594da9fbd0fabf6a850e3b5dfda962a0a067c1507411c92a84d1db2666ecf37
+DIST tmux-2.8.tar.gz 637609 BLAKE2B d95fbdbc79c2c512908f82778816aa8540bf2fe26509c91f46c8c64c8c13c9ea41487e3a816cc11274d4cc2868d16622c87efe978a65b08201c9a1c48e3c8c4b SHA512 d938854994e77f7941a31db79e25706150253feeba5e655a8fa853864e3073d2ee0ea218f972e7c7b9c814d8e8c63c2d9ef9b70ed1c6f8e993a900add4b995b5
DIST tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b 458 BLAKE2B 04143e6d1cfbbd467f1656f949363cb7a4a3e16e9b3cf56b8b0423babe56276abee2622964cb490005fc76d1cbe12201fb1a6446a6f860c2cc1ff3c9bd5fc496 SHA512 fe0aca7d03067af87e0788a2fa902c7ef5500ba72295cb63c5a1814534a008c224256d7f890ac1af6d17f3734b45148765e1632f075e284c453185df2927b979
DIST tmux.vim-95f6126c187667cc7f9c573c45c3b356cf69f4ca 5626 BLAKE2B dd22713fee56e3dadd573c888ab17561879f756df369cdbe552e052842f527c5310c6cd46342ccd3e3e01835d0f616f4ecb202567674dc4809bc08253ad66bea SHA512 956b2c1ca08e3c92aa39c9df54fbe1c661d0e076c91628c4b88f81f97104241b6505412fa0e21a681adc231eb2e6e7feee850474d4277812d186548bbb05f6d1
diff --git a/app-misc/tmux/tmux-2.8.ebuild b/app-misc/tmux/tmux-2.8.ebuild
new file mode 100644
index 000000000000..7200f8e5b512
--- /dev/null
+++ b/app-misc/tmux/tmux-2.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="https://tmux.github.io/"
+SRC_URI="https://github.com/tmux/tmux/releases/download/$(ver_cut 1-2)/${P}.tar.gz"
+SRC_URI="https://github.com/tmux/tmux/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
+
+CDEPEND="
+ dev-libs/libevent:0=
+ sys-libs/ncurses:0=
+ utempter? (
+ kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )"
+
+DOCS=( CHANGES README TODO )
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4-flags.patch
+
+ # usptream fixes (can be removed with next version bump)
+)
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ $(use_enable utempter)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ dodoc example_tmux.conf
+ docompress -x /usr/share/doc/${PF}/example_tmux.conf
+}
+
+pkg_postinst() {
+ if ! ver_test 1.9a -ge ${REPLACING_VERSIONS:-1.9a}; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}