summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-26 15:21:15 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-26 17:26:32 -0500
commit1171d9fc0a5e2f7a5cac6f8f2d9b24342bee8f75 (patch)
treec88f5979adf56e80f969f5666d6561f1100a0c63 /app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild
parentdev-java/ant-javamail: oracle-javamail non-virtual, kill jaf (#553188) (diff)
downloadgentoo-1171d9fc0a5e2f7a5cac6f8f2d9b24342bee8f75.tar.gz
gentoo-1171d9fc0a5e2f7a5cac6f8f2d9b24342bee8f75.tar.bz2
gentoo-1171d9fc0a5e2f7a5cac6f8f2d9b24342bee8f75.zip
app-misc/tpconfig: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild')
-rw-r--r--app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild b/app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..df31ea43a066
--- /dev/null
+++ b/app-misc/tpconfig/tpconfig-3.1.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Touchpad config for ALPS and Synaptics TPs. Controls tap/click behaviour"
+HOMEPAGE="http://www.compass.com/synaptics/"
+SRC_URI="http://www.compass.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin tpconfig || die "dobin failed!"
+ dodoc README AUTHORS NEWS INSTALL
+ doinitd "${FILESDIR}"/tpconfig
+ newconfd "${FILESDIR}"/tpconfig.conf tpconfig
+}