summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 21:39:20 +0000
committerSam James <sam@gentoo.org>2021-04-03 21:39:20 +0000
commit34148da3443371f23d80696158600791312df4a7 (patch)
treec09921a4639e718850ec71f930026fc2a81a21ad /app-misc/tprint
parentnet-news/yydecode: update EAPI 5 -> 7 (diff)
downloadgentoo-34148da3443371f23d80696158600791312df4a7.tar.gz
gentoo-34148da3443371f23d80696158600791312df4a7.tar.bz2
gentoo-34148da3443371f23d80696158600791312df4a7.zip
app-misc/tprint: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/tprint')
-rw-r--r--app-misc/tprint/tprint-1.1.0-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-misc/tprint/tprint-1.1.0-r1.ebuild b/app-misc/tprint/tprint-1.1.0-r1.ebuild
index b473dcc73077..fc7e22cc6f76 100644
--- a/app-misc/tprint/tprint-1.1.0-r1.ebuild
+++ b/app-misc/tprint/tprint-1.1.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,9 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE=""
src_prepare() {
+ default
+
sed -i Makefile \
-e 's:cc:$(CC):g' \
-e 's:-g -O2:$(CFLAGS) $(LDFLAGS):g' \
@@ -22,7 +23,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake CC="$(tc-getCC)"
}
src_install() {