summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-05-11 23:50:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-05-11 23:53:52 +0200
commit69e4846eefecae7b962e3c263b4828b93c2396e5 (patch)
tree66ec3050014770ad3b3cad78cfd646a23aaae45c /app-misc/transfolio
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-69e4846eefecae7b962e3c263b4828b93c2396e5.tar.gz
gentoo-69e4846eefecae7b962e3c263b4828b93c2396e5.tar.bz2
gentoo-69e4846eefecae7b962e3c263b4828b93c2396e5.zip
app-misc/transfolio: respect users ldflags
Closes: https://bugs.gentoo.org/722374 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/transfolio')
-rw-r--r--app-misc/transfolio/transfolio-1.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/transfolio/transfolio-1.0.1-r1.ebuild b/app-misc/transfolio/transfolio-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..fb39bd28deaf
--- /dev/null
+++ b/app-misc/transfolio/transfolio-1.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enables data transfer between the PC and the Atari Portfolio"
+HOMEPAGE="http://leute.server.de/peichl/"
+SRC_URI="http://leute.server.de/peichl/transfolio.zip -> ${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+
+ # Respect users CC, CFLAGS, LDFLAGS and disable striping
+ sed -e 's/cc/${CC}/' -e 's/-O2/${CFLAGS} ${LDFLAGS}/' -e '/strip/d' -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin transfolio
+
+ einstalldocs
+}