summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-08-20 22:19:00 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-09-05 15:37:12 +0300
commit132ac86bb4809a600c09607997c700a9ffd097fe (patch)
tree951201ccbc9ff65d68c10a9bc3fb7976f005c776 /app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
parentdev-python/spyder: update optional plugins list (diff)
downloadgentoo-132ac86bb4809a600c09607997c700a9ffd097fe.tar.gz
gentoo-132ac86bb4809a600c09607997c700a9ffd097fe.tar.bz2
gentoo-132ac86bb4809a600c09607997c700a9ffd097fe.zip
app-misc/trash-cli: add 0.22.8.21
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/26938 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.22.8.21.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.8.21.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.8.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}