summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-15 21:52:36 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-15 21:52:36 +0200
commita9374bd89c2a17d3a5f2d97409a5ccce93c9baa1 (patch)
tree127648178646bc434614f796160594232254cc5f /app-misc/ttysnoop/ttysnoop-0.12d.ebuild
parentsys-devel/pmake: Port to EAPI 7 (diff)
downloadgentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.tar.gz
gentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.tar.bz2
gentoo-a9374bd89c2a17d3a5f2d97409a5ccce93c9baa1.zip
app-misc/ttysnoop: Port to EAPI 7
Closes: https://bugs.gentoo.org/742071 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/ttysnoop/ttysnoop-0.12d.ebuild')
-rw-r--r--app-misc/ttysnoop/ttysnoop-0.12d.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
index 400e1e6c2c64..ccbb8cd23f2c 100644
--- a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
+++ b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
MY_P="${P}.k26"
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Tool to snoop on login tty's through another tty-device or pseudo-tty"
HOMEPAGE="http://sysd.org/stas/node/35"
@@ -14,30 +14,28 @@ SRC_URI="http://sysd.org/stas/files/active/0/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-DOCS="README snooptab.dist"
-
-src_prepare() {
- epatch "${FILESDIR}"/pinkbyte_masking.patch
- epatch "${FILESDIR}"/"${PN}"-makefile.patch
-}
+PATCHES=(
+ "${FILESDIR}"/pinkbyte_masking.patch
+ "${FILESDIR}"/"${PN}"-makefile.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
src_install() {
dodir /var/spool/ttysnoop
+ keepdir /var/spool/ttysnoop
+
fperms o= /var/spool/ttysnoop
- dodoc ${DOCS}
- dosbin ttysnoop
- dosbin ttysnoops
+
+ dosbin ttysnoop ttysnoops
+
+ dodoc README snooptab.dist
+
doman ttysnoop.8
insinto /etc
newins snooptab.dist snooptab