summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/usbirboy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/usbirboy')
-rw-r--r--app-misc/usbirboy/Manifest2
-rw-r--r--app-misc/usbirboy/files/usbirboy-0.2.1-kernel-2.6.16.diff43
-rw-r--r--app-misc/usbirboy/files/usbirboy-0.2.1-module_param.diff23
-rw-r--r--app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff48
-rw-r--r--app-misc/usbirboy/metadata.xml8
-rw-r--r--app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild65
-rw-r--r--app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild57
-rw-r--r--app-misc/usbirboy/usbirboy-0.3.1.ebuild57
8 files changed, 303 insertions, 0 deletions
diff --git a/app-misc/usbirboy/Manifest b/app-misc/usbirboy/Manifest
new file mode 100644
index 000000000000..99ca6f47fe05
--- /dev/null
+++ b/app-misc/usbirboy/Manifest
@@ -0,0 +1,2 @@
+DIST usbirboy-0.2.1.tar.gz 38664 SHA256 144e6e29dcce004f4999e2f90551529346516c478ae0773f753fda3abaed3ffd SHA512 f26daa847214f60e0883f261cf11d758f0d7a61434e2ec3c7dcee9862362d4a0d16225619cf920528a9a40f245eee97a3531112c1b57e1bec4d191a4196f161c WHIRLPOOL b1b31cdf874d8b0c040f4921bcab47d5292fba56600cab64c9b8e340c04267f3f1099473aa250043e775176cb0df4ba6b6eb1e4ee9616a7482ebfd95dfe652ab
+DIST usbirboy-0.3.1.tar.gz 49649 SHA256 cb879c1c67bb8deba385a12d5d97ca9ea6b148e77d1cd985a4fa3054b71d5cc6 SHA512 49f5c9eed4272b3066a87bfbacf95b39f1912a0fd22e580a87cf6b850e4ce98adb2c7ffb08b4c3db6d5b9cf298caa279ebeb51372eb95b9edf0b1ca02ecfba60 WHIRLPOOL e542f81644ca84953b2c789676a8f7b469358e0283262cb4881dfe0e4e87b8c140b5b47c68699057bcf5ccff0ba9771dfcd40ed1859d945604223c6e2e6084c0
diff --git a/app-misc/usbirboy/files/usbirboy-0.2.1-kernel-2.6.16.diff b/app-misc/usbirboy/files/usbirboy-0.2.1-kernel-2.6.16.diff
new file mode 100644
index 000000000000..bc2a2f0b3194
--- /dev/null
+++ b/app-misc/usbirboy/files/usbirboy-0.2.1-kernel-2.6.16.diff
@@ -0,0 +1,43 @@
+diff -ru usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c usbirboy-0.2.1/usbirboykmod/usbirboy.c
+--- usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c 2006-06-08 07:52:54.211338228 +0200
++++ usbirboy-0.2.1/usbirboykmod/usbirboy.c 2006-06-08 07:57:26.989743855 +0200
+@@ -76,6 +76,14 @@
+ #define LIRC_SET_REC_MODE _IOW('i', 0x00000012, __u32)
+
+
++#include <linux/version.h>
++
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,16)
++#define USBIRBOY_THIS_MODULE(x) x,
++#else /* >= 2.6.16 */
++#define USBIRBOY_THIS_MODULE(x)
++#endif
++
+
+ /* prevent races between open() and disconnect() */
+ static DECLARE_MUTEX (disconnect_sem);
+@@ -778,7 +784,7 @@
+
+ /*defines user space function bodies*/
+ static struct file_operations usbirboy_fops = {
+- .owner = THIS_MODULE,
++ USBIRBOY_THIS_MODULE(.owner = THIS_MODULE)
+ .read = usbirboy_user_read,
+ .ioctl = usbirboy_user_ioctl,
+ .open = usbirboy_user_open,
+@@ -790,13 +796,13 @@
+ static struct usb_class_driver usbirboy_class = {
+ .name = DRIVER_NAME,
+ .fops = &usbirboy_fops,
+- .mode = S_IFCHR | S_IRUSR | S_IRGRP | S_IROTH,
++ USBIRBOY_THIS_MODULE(.mode = S_IFCHR | S_IRUSR | S_IRGRP | S_IROTH)
+ .minor_base = USBIRBOY_MINOR_BASE,
+ };
+
+ /*driver info for kernel*/
+ static struct usb_driver usbirboy_driver = {
+- .owner = THIS_MODULE,
++ USBIRBOY_THIS_MODULE(.owner = THIS_MODULE)
+ .name = DRIVER_NAME,
+ .id_table = usbirboy_device_table,
+ .probe = usbirboy_usb_probe,
diff --git a/app-misc/usbirboy/files/usbirboy-0.2.1-module_param.diff b/app-misc/usbirboy/files/usbirboy-0.2.1-module_param.diff
new file mode 100644
index 000000000000..176ed375fb72
--- /dev/null
+++ b/app-misc/usbirboy/files/usbirboy-0.2.1-module_param.diff
@@ -0,0 +1,23 @@
+Nur in usbirboy-0.2.1/usbirboykmod: Modules.symvers.
+Nur in usbirboy-0.2.1/usbirboykmod/.tmp_versions: usbirboy.mod.
+diff -ru usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c usbirboy-0.2.1/usbirboykmod/usbirboy.c
+--- usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c 2006-07-03 10:30:07.393102962 +0200
++++ usbirboy-0.2.1/usbirboykmod/usbirboy.c 2006-07-03 10:34:02.999771952 +0200
+@@ -90,7 +90,8 @@
+
+ /* define debug kernel option */
+ static int debug = 0;
+-MODULE_PARM(debug, "i");
++module_param(debug, bool, 0644);
++MODULE_PARM_DESC(debug, "Enable debugging messages");
+
+ static struct usb_driver usbirboy_driver;
+ static struct usb_class_driver usbirboy_class;
+Nur in usbirboy-0.2.1/usbirboykmod: usbirboy.ko.
+Nur in usbirboy-0.2.1/usbirboykmod: .usbirboy.ko.cmd.
+Nur in usbirboy-0.2.1/usbirboykmod: usbirboy.mod.c.
+Nur in usbirboy-0.2.1/usbirboykmod: usbirboy.mod.o.
+Nur in usbirboy-0.2.1/usbirboykmod: .usbirboy.mod.o.cmd.
+Nur in usbirboy-0.2.1/usbirboykmod: usbirboy.o.
+Nur in usbirboy-0.2.1/usbirboykmod: .usbirboy.o.cmd.
+Nur in usbirboy-0.2.1-orig/usbirboykmod: .usbirboy.o.d.
diff --git a/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff b/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff
new file mode 100644
index 000000000000..8cac30623f9c
--- /dev/null
+++ b/app-misc/usbirboy/files/usbirboy-0.2.1-nice-kernel-msgs.diff
@@ -0,0 +1,48 @@
+diff -ru usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c usbirboy-0.2.1/usbirboykmod/usbirboy.c
+--- usbirboy-0.2.1-orig/usbirboykmod/usbirboy.c 2006-07-06 11:47:10.353523729 +0200
++++ usbirboy-0.2.1/usbirboykmod/usbirboy.c 2006-07-06 11:49:45.352506621 +0200
+@@ -65,6 +65,8 @@
+ #define __END_DEBUG }
+
+
++#define usbirboy_info(format, arg...) printk(KERN_INFO "%s: " format "\n" , \
++ DRIVER_NAME , ## arg)
+
+ /* Strait from lirc.h adopted ioctl definitions */
+ /* Lets hope they dont change those*/
+@@ -636,7 +638,7 @@
+
+
+ /* let the user know what node this device is now attached to */
+- info("USB-IR-Boy device attached to usbirboy with minor %d\n", irdev->minor);
++ usbirboy_info("USB-IR-Boy device attached to usbirboy with minor %d", irdev->minor);
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
+@@ -725,7 +727,7 @@
+ usbirboy_cleanup (usbirdev);
+ up (&disconnect_sem);
+
+- info( "USB-IR-Boy device disconnected. Minor: %d\n",minor);
++ usbirboy_info( "USB-IR-Boy device disconnected. Minor: %d",minor);
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
+@@ -754,7 +756,7 @@
+ return -1;
+ }
+
+- info( DRIVER_DESC ":" DRIVER_VERSION);
++ usbirboy_info( DRIVER_DESC ":" DRIVER_VERSION);
+
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+@@ -772,7 +774,7 @@
+ __END_DEBUG
+ usb_deregister (&usbirboy_driver);
+
+- info( "usbirboy_driver deregistered...\n");
++ usbirboy_info( "driver deregistered...");
+ __DEBUG
+ printk("<----- %s \n", __FUNCTION__);
+ __END_DEBUG
diff --git a/app-misc/usbirboy/metadata.xml b/app-misc/usbirboy/metadata.xml
new file mode 100644
index 000000000000..d07e38bcb915
--- /dev/null
+++ b/app-misc/usbirboy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <upstream>
+ <remote-id type="sourceforge">usbirboy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ba716fc47dc3
--- /dev/null
+++ b/app-misc/usbirboy/usbirboy-0.2.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod eutils
+
+DESCRIPTION="Use home made infrared receiver connected via USB"
+HOMEPAGE="http://usbirboy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ia64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/usbirboykmod"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is -ge 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ if ! linux_chkconfig_present USB; then
+ die "You need a kernel with enabled USB support!"
+ fi
+
+ MODULE_NAMES="usbirboy(misc:${S})"
+ BUILD_PARAMS="INCLUDE=${KV_DIR}"
+ BUILD_TARGETS="default"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-kernel-2.6.16.diff"
+ epatch "${FILESDIR}/${P}-module_param.diff"
+ epatch "${FILESDIR}/${P}-nice-kernel-msgs.diff"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ newdoc ../usbirboymcu/README README.mcu
+
+ insinto /usr/share/${PN}
+ doins ../mcubin/usbirboy.s19
+
+ # Add configuration for udev
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="usbirboy", NAME="%k", SYMLINK="lirc"' \
+ > "${D}etc/udev/rules.d/55-${PN}.rules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog
+ elog "Firmware file has been installed to /usr/share/${PN}"
+ elog
+}
diff --git a/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild b/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..fe9b8383adac
--- /dev/null
+++ b/app-misc/usbirboy/usbirboy-0.3.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod eutils
+
+DESCRIPTION="Use home made infrared receiver connected via USB"
+HOMEPAGE="http://usbirboy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/usbirboykmod"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is -ge 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ if ! linux_chkconfig_present USB; then
+ die "You need a kernel with enabled USB support!"
+ fi
+
+ MODULE_NAMES="usbirboy(misc:${S})"
+ BUILD_PARAMS="INCLUDE=${KV_DIR}"
+ BUILD_TARGETS="clean all"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ newdoc ../usbirboymcu/README README.mcu
+
+ insinto /usr/share/${PN}
+ doins ../mcubin/usbirboy.s19
+
+ # Add configuration for udev
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="usbirboy", SYMLINK+="lirc"' \
+ > "${D}etc/udev/rules.d/30-${PN}.rules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog
+ elog "Firmware file has been installed to /usr/share/${PN}"
+ elog
+}
diff --git a/app-misc/usbirboy/usbirboy-0.3.1.ebuild b/app-misc/usbirboy/usbirboy-0.3.1.ebuild
new file mode 100644
index 000000000000..c25c5ead0c75
--- /dev/null
+++ b/app-misc/usbirboy/usbirboy-0.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod eutils
+
+DESCRIPTION="Use home made infrared receiver connected via USB"
+HOMEPAGE="http://usbirboy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/usbirboykmod"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is -ge 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ if ! linux_chkconfig_present USB; then
+ die "You need a kernel with enabled USB support!"
+ fi
+
+ MODULE_NAMES="usbirboy(misc:${S})"
+ BUILD_PARAMS="INCLUDE=${KV_DIR}"
+ BUILD_TARGETS="clean all"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+ newdoc ../usbirboymcu/README README.mcu
+
+ insinto /usr/share/${PN}
+ doins ../mcubin/usbirboy.s19
+
+ # Add configuration for udev
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="usbirboy", NAME="%k", SYMLINK="lirc"' \
+ > "${D}etc/udev/rules.d/55-${PN}.rules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog
+ elog "Firmware file has been installed to /usr/share/${PN}"
+ elog
+}