summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 12:50:11 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 12:50:11 +0100
commit1f02614a2f744c3bc9073a1cc4984a875747bc96 (patch)
treea64d298bb62f4561d17e6928d68dd09fd59d6e26 /app-misc/utimer
parentdev-ml/camlp4: restore 4.05_p1 (diff)
downloadgentoo-1f02614a2f744c3bc9073a1cc4984a875747bc96.tar.gz
gentoo-1f02614a2f744c3bc9073a1cc4984a875747bc96.tar.bz2
gentoo-1f02614a2f744c3bc9073a1cc4984a875747bc96.zip
app-misc/utimer: Port to EAPI 7
* Thanks to Jeroen Roovers for submitting the fno-common patch Closes: https://bugs.gentoo.org/717250 Closes: https://bugs.gentoo.org/709300 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/utimer')
-rw-r--r--app-misc/utimer/files/utimer-0.4-fno-common.patch29
-rw-r--r--app-misc/utimer/files/utimer-0.4-locale.patch10
-rw-r--r--app-misc/utimer/utimer-0.4-r1.ebuild24
3 files changed, 50 insertions, 13 deletions
diff --git a/app-misc/utimer/files/utimer-0.4-fno-common.patch b/app-misc/utimer/files/utimer-0.4-fno-common.patch
new file mode 100644
index 000000000000..a8386fe8e215
--- /dev/null
+++ b/app-misc/utimer/files/utimer-0.4-fno-common.patch
@@ -0,0 +1,29 @@
+--- a/src/utimer.h
++++ b/src/utimer.h
+@@ -66,9 +66,9 @@
+ #define TIMER_PRINT_RATE_MSEC 79
+ #define TIMER_CHECK_RATE_MSEC 500
+
+-GMainLoop *loop;
+-gboolean paused;
+-struct termios savedttystate;
+-Config ut_config;
++extern GMainLoop *loop;
++extern gboolean paused;
++extern struct termios savedttystate;
++extern Config ut_config;
+
+ #endif /* UTIMER_H */
+--- a/src/utils.c
++++ b/src/utils.c
+@@ -36,6 +36,10 @@
+ #include "utils.h"
+ #include "utimer.h"
+
++GMainLoop *loop;
++gboolean paused;
++struct termios savedttystate;
++Config ut_config;
+
+ gulong ul_add (gulong a, gulong b)
+ {
diff --git a/app-misc/utimer/files/utimer-0.4-locale.patch b/app-misc/utimer/files/utimer-0.4-locale.patch
new file mode 100644
index 000000000000..68acdd471a39
--- /dev/null
+++ b/app-misc/utimer/files/utimer-0.4-locale.patch
@@ -0,0 +1,10 @@
+--- a/src/utimer.h
++++ b/src/utimer.h
+@@ -35,6 +35,7 @@
+ #include <stdlib.h>
+ #include <glib.h>
+ #include <glib/gi18n-lib.h>
++#include <locale.h>
+
+ #include "utils.h"
+ #include "timer.h"
diff --git a/app-misc/utimer/utimer-0.4-r1.ebuild b/app-misc/utimer/utimer-0.4-r1.ebuild
index bf5c8f9fd36b..d3055fbb083f 100644
--- a/app-misc/utimer/utimer-0.4-r1.ebuild
+++ b/app-misc/utimer/utimer-0.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="A command line timer and stopwatch"
HOMEPAGE="http://utimer.codealpha.net/utimer"
@@ -12,21 +12,19 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug nls"
-DEPEND="
+RDEPEND="
dev-libs/glib:2
dev-util/intltool"
+DEPEND="${RDEPEND}"
-RDEPEND="${RDEPEND}"
-
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-locale.patch
+)
DOCS=( AUTHORS ChangeLog NEWS README )
src_configure() {
- local myconf=( --enable-debug=no )
- use debug || myconf=( --enable-debug=yes )
- econf "${myconf[@]}" $(use_enable nls)
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- einstalldocs
+ econf \
+ $(use_enable debug) \
+ $(use_enable nls)
}