summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/vifm/vifm-0.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/vifm/vifm-0.8.ebuild')
-rw-r--r--app-misc/vifm/vifm-0.8.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/app-misc/vifm/vifm-0.8.ebuild b/app-misc/vifm/vifm-0.8.ebuild
new file mode 100644
index 000000000000..01d28b9ec95a
--- /dev/null
+++ b/app-misc/vifm/vifm-0.8.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools vim-doc
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="http://vifm.info/"
+SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+IUSE="X developer +extended-keys gtk +magic vim vim-syntax"
+
+DEPEND="
+ >=sys-libs/ncurses-5.7-r7
+ magic? ( sys-apps/file )
+ gtk? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="
+ ${DEPEND}
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+
+DOCS="AUTHORS FAQ NEWS README TODO"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable developer) \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic) \
+ $(use_with gtk) \
+ $(use_with X X11)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ einstall
+ dodoc ${DOCS}
+
+ if use vim; then
+ local t
+ for t in app plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/doc/"${t}"/"${PN}"*
+ done
+ fi
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins "${S}"/data/vim/"${t}"/"${PN}".vim
+ done
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ if use vim; then
+ update_vim_helptags
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You don't need to copy or link any files for"
+ elog " the vim plugin and documentation to work anymore."
+ elog "If you copied any vifm files to ~/.vim/ manually"
+ elog " in earlier vifm versions, please delete them."
+ fi
+ elog
+ elog "To use vim in vifm to view the documentation"
+ elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ use vim && update_vim_helptags
+}