summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-04 14:37:13 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-04 14:37:53 +0100
commitd976b59884bf7bbe9415d6c9950d90f4b4f0b1c0 (patch)
tree595358ca0eb603827a95e3b5067892a6039e1e01 /app-misc/wcd/files
parentmedia-gfx/nvidia-texture-tools: upgrade to EAPI=6 (diff)
downloadgentoo-d976b59884bf7bbe9415d6c9950d90f4b4f0b1c0.tar.gz
gentoo-d976b59884bf7bbe9415d6c9950d90f4b4f0b1c0.tar.bz2
gentoo-d976b59884bf7bbe9415d6c9950d90f4b4f0b1c0.zip
app-misc/wcd: Bump to version 5.3.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/wcd/files')
-rw-r--r--app-misc/wcd/files/wcd-5.3.4-gentoo.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/wcd/files/wcd-5.3.4-gentoo.patch b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
new file mode 100644
index 000000000000..0839bdb069d9
--- /dev/null
+++ b/app-misc/wcd/files/wcd-5.3.4-gentoo.patch
@@ -0,0 +1,67 @@
+--- wcd-5.3.4/src/Makefile
++++ wcd-5.3.4/src/Makefile
+@@ -46,12 +46,12 @@
+
+ CC ?= gcc
+ STATIC =
+-STRIP = strip
++STRIP =
+
+ ENABLE_NLS = 1
+
+ PACKAGE = wcd
+-EXT = .exe
++EXT =
+ PROGRAM = $(PACKAGE)$(EXT)
+ BIN = $(PROGRAM)
+
+@@ -334,9 +334,9 @@
+ # possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
+
+ ifdef UCS
+- CURSES = ncursesw
++ CURSES = $(shell pkg-config --libs ncursesw)
+ else
+- CURSES = ncurses
++ CURSES = $(shell pkg-config --libs ncurses)
+ endif
+
+
+@@ -366,7 +366,7 @@
+
+ ifneq (,$(CURSES))
+ DEFS_CURSES = -DWCD_USECURSES
+- LIB_CURSES = -l$(CURSES)
++ LIB_CURSES = $(CURSES)
+ ifeq (os/2,$(OS))
+ LIB_CURSES += -ltinfo
+ endif
+@@ -456,15 +456,15 @@
+ endif
+
+ LDFLAGS_USER =
+-LDFLAGS = $(RPM_OPT_FLAGS) \
++LIBS = $(RPM_OPT_FLAGS) \
+ $(LDFLAGS_EXTRA) \
+ $(NLFLAG) \
+ $(LDFLAG_STATIC) \
+ $(LDFLAGS_USER)
+
+-LIBS = $(LIB_CURSES) \
+- $(LIB_UNISTRING) \
+- $(LIBS_EXTRA)
++LIBS += $(LIB_CURSES) \
++ $(LIB_UNISTRING) \
++ $(LIBS_EXTRA)
+
+ DEFS_USER =
+ DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
+@@ -521,7 +521,7 @@
+
+ $(BIN): $(OBJS1)
+ $(MAKE) status
+- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@