summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-04-23 19:07:21 -0700
committerZac Medico <zmedico@gentoo.org>2021-04-23 20:17:07 -0700
commit67f01ef43a26009e95bd8edfd8598c5f45e578bf (patch)
tree00b653d44b16020869c69b75e0f658cbefc803eb /app-misc/wildq
parentdev-python/jq: DISTUTILS_USE_SETUPTOOLS=bdepend (diff)
downloadgentoo-67f01ef43a26009e95bd8edfd8598c5f45e578bf.tar.gz
gentoo-67f01ef43a26009e95bd8edfd8598c5f45e578bf.tar.bz2
gentoo-67f01ef43a26009e95bd8edfd8598c5f45e578bf.zip
app-misc/wildq: Initial import
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-misc/wildq')
-rw-r--r--app-misc/wildq/Manifest1
-rw-r--r--app-misc/wildq/metadata.xml16
-rw-r--r--app-misc/wildq/wildq-1.1.10.ebuild28
3 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/wildq/Manifest b/app-misc/wildq/Manifest
new file mode 100644
index 000000000000..a360e0aadfad
--- /dev/null
+++ b/app-misc/wildq/Manifest
@@ -0,0 +1 @@
+DIST wildq-1.1.10.tar.gz 16049 BLAKE2B ffb365e7dee7770a0ab52d189b59f1a8a9e6b2c8a63439d884b29fc7182b523eb38e2ada0ce9581d637fed9035dc5f7fc0197451bb4fcafd1d54746b0c0112af SHA512 cf10cd10757e6b933ecc11167c5ad4c548dfbfa9edad030458736ba6d29e816bb214c111fa96fa2625160d6403758d936c8374d6dc26b528e6ae22ed947de5bc
diff --git a/app-misc/wildq/metadata.xml b/app-misc/wildq/metadata.xml
new file mode 100644
index 000000000000..215bdfd0e991
--- /dev/null
+++ b/app-misc/wildq/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">wildq</remote-id>
+ <remote-id type="github">ahmet2mir/wildq</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="hcl">HCL support via pyhcl</flag>
+ <flag name="toml">TOML support via pytoml</flag>
+ <flag name="xml">XML support via xmltodict</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/wildq/wildq-1.1.10.ebuild b/app-misc/wildq/wildq-1.1.10.ebuild
new file mode 100644
index 000000000000..ccc4444aac82
--- /dev/null
+++ b/app-misc/wildq/wildq-1.1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line TOML/JSON/INI/YAML/XML processor using jq c bindings"
+HOMEPAGE="https://pypi.org/project/wildq/ https://github.com/ahmet2mir/wildq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hcl toml xml"
+RDEPEND="
+ dev-python/jq[${PYTHON_USEDEP}]
+ hcl? ( dev-python/pyhcl[${PYTHON_USEDEP}] )
+ toml? ( dev-python/toml[${PYTHON_USEDEP}] )
+ xml? ( dev-python/xmltodict[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ # Unpin install_requires versions.
+ sed -e "s|^\\([ []'[[:alnum:]]\+\\)>=[^']*|\\1|" -i setup.py || die
+ distutils-r1_python_prepare_all
+}