summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/xmind/xmind-3.4.1.201401221918.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/xmind/xmind-3.4.1.201401221918.ebuild')
-rw-r--r--app-misc/xmind/xmind-3.4.1.201401221918.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/app-misc/xmind/xmind-3.4.1.201401221918.ebuild b/app-misc/xmind/xmind-3.4.1.201401221918.ebuild
new file mode 100644
index 000000000000..91fe2883470f
--- /dev/null
+++ b/app-misc/xmind/xmind-3.4.1.201401221918.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib gnome2-utils
+
+MY_PN="${PN}-portable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A brainstorming and mind mapping software tool"
+HOMEPAGE="http://www.xmind.net"
+SRC_URI="http://dl2.xmind.net/xmind-downloads/${MY_P}.zip
+ http://dev.gentoo.org/~creffett/distfiles/xmind-icons.tar.xz"
+LICENSE="EPL-1.0 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5
+ x11-libs/gtk+:2
+"
+
+S=${WORKDIR}
+
+QA_PRESTRIPPED="opt/xmind/XMind/libcairo-swt.so"
+QA_FLAGS_IGNORED="
+ opt/xmind/Commons/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120522-1813/eclipse_1502.so
+ opt/xmind/Commons/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20120522-1813/eclipse_1502.so
+ opt/xmind/XMind/libcairo-swt.so
+ opt/xmind/XMind/XMind
+"
+
+src_configure() {
+ if use amd64; then
+ XDIR="XMind_Linux_64bit"
+ else
+ XDIR="XMind_Linux"
+ fi
+ mv "$XDIR" XMind || die
+ mv XMind/.eclipseproduct Commons || die
+ cp "${FILESDIR}"/${PN}-3.4.0-config.ini Commons/configuration || die #Combined common+linux config.ini
+ # force data instance & config area to be at home/.xmind directory
+ sed -i -e '/-configuration/d' \
+ -e '/\.\/configuration/d' \
+ -e '/-data/d' \
+ -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
+ -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' XMind/XMind.ini || die
+ echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/XMind.ini || die
+ echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/XMind.ini || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /opt/xmind
+ doins -r Commons XMind || die
+ fperms a+rx "/opt/xmind/XMind/XMind"
+
+ dodir /opt/bin
+ exeinto /opt/bin
+ newexe "${FILESDIR}/xmind-wrapper" xmind
+
+ # install icons
+ local res
+ for res in 16 32 48; do
+ newicon -s ${res} "${WORKDIR}/xmind-icons/xmind.${res}.png" xmind.png
+ done
+
+ # make desktop entry
+ make_desktop_entry "xmind %F" XMind xmind Office "MimeType=application/x-xmind;"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "For audio notes support, install media-sound/lame"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}