summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPunarbasu 'ppurka' Purkayastha <ppurka@gmail.com>2019-05-05 19:48:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-08 19:03:32 +0200
commit062b42a3da95e7d0ba19fd8b204f25b89f652448 (patch)
tree41af97716f95d2cf7c0b0e137d2325ce0d175712 /app-misc
parentsys-block/partitionmanager: add ~arm64 keywords (diff)
downloadgentoo-062b42a3da95e7d0ba19fd8b204f25b89f652448.tar.gz
gentoo-062b42a3da95e7d0ba19fd8b204f25b89f652448.tar.bz2
gentoo-062b42a3da95e7d0ba19fd8b204f25b89f652448.zip
app-misc/recoll: 1.25.15 version bump, EAPI-7 bump, USE chm,webengine
Drop dev-qt/qtwebkit option. Closes: https://bugs.gentoo.org/680468 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/recoll/Manifest1
-rw-r--r--app-misc/recoll/metadata.xml2
-rw-r--r--app-misc/recoll/recoll-1.25.15.ebuild134
3 files changed, 137 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 813a20ac0f44..d077ba98df1d 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1 +1,2 @@
DIST recoll-1.24.1.tar.gz 2644672 BLAKE2B e5bce2231e075fe9a2bfad7d0d1068906e625106b09247dc5baffaf92957db111dd6be90c658266b8b9940d885b3495769c68ce66247d00568df24c1b5222226 SHA512 60bf57d2718a21dbd578fa1dc73a542fc7ab2152c4c5bb763885b19c14d080340587cb8c01f82f1ca7d1cb63a03edf03b4501f3ef63f06ab6506356c4a0a095c
+DIST recoll-1.25.15.tar.gz 2843434 BLAKE2B 7facf6040560ab11b7a3d99b583020bdd4757157236a23430381c9d6932de558917f5dd1faf0f1ca87be3386307b5346ec66bb82637edd42035fd7be61ee9b39 SHA512 acd5349e1a1edd6ca22f819b0cfe76161fedb0bde8b4a86e679e78d68d090481a11a8d1980764d008074846b5033481c766e624da1322ab318b52c9c9c57104c
diff --git a/app-misc/recoll/metadata.xml b/app-misc/recoll/metadata.xml
index 1e89b50bb67b..80572eb1e414 100644
--- a/app-misc/recoll/metadata.xml
+++ b/app-misc/recoll/metadata.xml
@@ -18,8 +18,10 @@
</upstream>
<use>
<flag name="camelcase">Enable indexing for camelCase sentences and words</flag>
+ <flag name="chm">Enable CHM file support via <pkg>dev-python/pychm</pkg></flag>
<flag name="inotify">Use the Linux Kernel notification subsystem for monitoring file alterations in realtime</flag>
<flag name="session">Stop monitoring file alterations when X11 session terminates</flag>
+ <flag name="webengine">Use <pkg>dev-qt/qtwebengine</pkg> for fancy result list display</flag>
</use>
<longdescription lang="en">
Recoll is a desktop full-text search tool. It can search most document
diff --git a/app-misc/recoll/recoll-1.25.15.ebuild b/app-misc/recoll/recoll-1.25.15.ebuild
new file mode 100644
index 000000000000..05fa308a893f
--- /dev/null
+++ b/app-misc/recoll/recoll-1.25.15.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit eutils linux-info python-single-r1 qmake-utils
+
+DESCRIPTION="A personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase chm doc +inotify qt5 session +spell webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/xapian:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_pretend() {
+ if has_version "<app-misc/recoll-1.20"; then
+ elog "Installing ${PV} over an 1.19 index is possible,"
+ elog "but there have been small changes in the way"
+ elog "compound words are indexed. So it is best to reset"
+ elog "the index. The best method to reset the index is to"
+ elog "quit all recoll programs and delete the index directory"
+ elog "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
+ fi
+}
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true)" DESTDIR="${D}" install
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ use doc && dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "In order to extract the full functionality of "
+ elog "recoll, the following packages should be installed "
+ elog "to get the corresponding document support."
+
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}