summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-11 20:47:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-11 21:23:48 +0200
commit1f6b576ad4d33b0f8277d867b1df8d12d565b4c2 (patch)
treea3ee191450a5dbd653dfb964397d08e5ab3042ef /app-misc
parentapp-crypt/gnupg-pkcs11-scd: migrate to GLEP 81 (diff)
downloadgentoo-1f6b576ad4d33b0f8277d867b1df8d12d565b4c2.tar.gz
gentoo-1f6b576ad4d33b0f8277d867b1df8d12d565b4c2.tar.bz2
gentoo-1f6b576ad4d33b0f8277d867b1df8d12d565b4c2.zip
app-misc/notary: migrate to GLEP 81
Closes: https://bugs.gentoo.org/781260 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/notary/notary-0.6.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/notary/notary-0.6.1-r2.ebuild b/app-misc/notary/notary-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..840f089bb574
--- /dev/null
+++ b/app-misc/notary/notary-0.6.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot golang-build
+
+KEYWORDS="~amd64"
+DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
+EGO_PN="github.com/theupdateframework/notary"
+GIT_COMMIT="d6e1431feb32348e0650bf7551ac5cffd01d857b"
+
+HOMEPAGE="https://github.com/theupdateframework/notary"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ acct-group/notary
+ acct-user/notary
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary-server || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary-signer || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/${PN}{,-server,-signer}
+ pushd src/${EGO_PN} || die
+ insinto /var/lib/notary
+ doins -r migrations fixtures
+ fowners -R ${PN}:${PN} /var/lib/notary
+ fperms -R 0600 /var/lib/notary/fixtures/database/
+ newinitd "${FILESDIR}"/notary-signer.initd notary-signer
+ newconfd "${FILESDIR}"/notary-signer.confd notary-signer
+ newinitd "${FILESDIR}"/notary-server.initd notary-server
+ newconfd "${FILESDIR}"/notary-server.confd notary-server
+}