summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-02-13 10:06:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-02-13 12:55:40 +0100
commit23e9991e1bfdfe1ea2331459fdaf8f64fc253274 (patch)
treeb77e2545585b14952d0cdfaf8f072bfcf53d4f2e /app-misc
parentdev-qt/qtcore: Fix headers for revdeps building with GCC-11 (diff)
downloadgentoo-23e9991e1bfdfe1ea2331459fdaf8f64fc253274.tar.gz
gentoo-23e9991e1bfdfe1ea2331459fdaf8f64fc253274.tar.bz2
gentoo-23e9991e1bfdfe1ea2331459fdaf8f64fc253274.zip
app-misc/radeontop: add dependency on amd radeon gpus, fixes #768549
Closes: https://github.com/gentoo/gentoo/pull/19350 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/radeontop/radeontop-1.3-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/radeontop/radeontop-1.3-r1.ebuild b/app-misc/radeontop/radeontop-1.3-r1.ebuild
new file mode 100644
index 000000000000..c82aa5733c6a
--- /dev/null
+++ b/app-misc/radeontop/radeontop-1.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls video_cards_amdgpu video_cards_radeon"
+REQUIRED_USE="
+ || ( video_cards_amdgpu video_cards_radeon )
+"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ x11-libs/libdrm[video_cards_amdgpu?,video_cards_radeon?]
+ x11-libs/libpciaccess
+ x11-libs/libxcb
+ nls? (
+ sys-libs/ncurses:0=[unicode]
+ virtual/libintl
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ cat > include/version.h <<-EOF || die
+ #ifndef VER_H
+ #define VER_H
+
+ #define VERSION "${PV}"
+
+ #endif
+ EOF
+ >getver.sh || die
+ touch .git || die
+}
+
+src_configure() {
+ tc-export CC
+ export LIBDIR=$(get_libdir)
+ export nls=$(usex nls 1 0)
+ export amdgpu=1
+ export xcb=1
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}