summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-01-11 21:46:46 +0000
committerPatrick McLean <chutzpah@gentoo.org>2022-01-11 14:15:52 -0800
commit2b26584a7594b291b3e0e3a51691faa1a720afea (patch)
treef4587689efb0131322c60c97fb1e6ac19d2ce579 /app-misc
parentapp-misc/openrgb: sync live (diff)
downloadgentoo-2b26584a7594b291b3e0e3a51691faa1a720afea.tar.gz
gentoo-2b26584a7594b291b3e0e3a51691faa1a720afea.tar.bz2
gentoo-2b26584a7594b291b3e0e3a51691faa1a720afea.zip
app-misc/openrgb-plugin-effects: update to openrgb 0.7
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/openrgb-plugin-effects/Manifest1
-rw-r--r--app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0_p20220110-dep.patch16
-rw-r--r--app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20220110.ebuild49
3 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-effects/Manifest b/app-misc/openrgb-plugin-effects/Manifest
index b88ac276fe9e..55c32040a0ed 100644
--- a/app-misc/openrgb-plugin-effects/Manifest
+++ b/app-misc/openrgb-plugin-effects/Manifest
@@ -1 +1,2 @@
+DIST OpenRGBEffectsPlugin-a7222bdbcd3c52e13d96993a33c5648f1306aeba.tar.bz2 255129 BLAKE2B 8fc7ee994d80bd9fe8d8a76e26710ed0fec429aa8df835f6a46a64d4034a4fc2352d722c9aed26032bff33781b1f024a893d685f6883e1816872d91cd937c1d0 SHA512 386879a7a1f05cfcbcca792add1b18f2680b4fa7b139f8532e6f32d09a5194c381357d3cbb3883352c2a03280c9b0b0f1e9faef7e140c7535144c0d645832d3e
DIST OpenRGBEffectsPlugin-a8ea7eef586d9dc341fbe67f60cb8cb4d69a9504.tar.bz2 345726 BLAKE2B e8cf741ba935521c449d3b2a326a44b709c919cb3e3694cbd07939205b8f589dcc00b46cdb1f08684e4e4d3d0a798aade7c051ebc16c3c82368fbeb94ec84fb5 SHA512 134b46090386f94fcf77c4a0a1807ac94ecb8323f318e01098a1edf9b3cf555dbc7f1c5abce484dd4aba9cea32ae7aac5abc0f5f1d26e8edee4afe197f5a254f
diff --git a/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0_p20220110-dep.patch b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0_p20220110-dep.patch
new file mode 100644
index 000000000000..7ab0f2ca75f9
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/files/openrgb-plugin-effects-0_p20220110-dep.patch
@@ -0,0 +1,16 @@
+Fix dependency on app-misc/openrgb
+
+--- a/OpenRGBEffectsPlugin.pro
++++ b/OpenRGBEffectsPlugin.pro
+@@ -64,11 +64,6 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+
+-SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+- OpenRGB/dependencies/ColorWheel/ColorWheel.cpp \
+- OpenRGB/qt/hsv.cpp \
+-
+ #-----------------------------------------------------------------------------------------------#
+ # QCodeEditor #
+ #-----------------------------------------------------------------------------------------------#
diff --git a/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20220110.ebuild b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20220110.ebuild
new file mode 100644
index 000000000000..0d8ec005a69c
--- /dev/null
+++ b/app-misc/openrgb-plugin-effects/openrgb-plugin-effects-0_p20220110.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_GIT_COMMIT="a7222bdbcd3c52e13d96993a33c5648f1306aeba"
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin/-/archive/${MY_GIT_COMMIT}/OpenRGBEffectsPlugin-${MY_GIT_COMMIT}.tar.bz2"
+S="${WORKDIR}/OpenRGBEffectsPlugin-${MY_GIT_COMMIT}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB with various Effects that can be synced across devices"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBEffectsPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.7:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/openal
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/openrgb-plugin-effects-0_p20220110-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBEffectsPlugin.so.1.0
+}