summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 21:31:31 +0000
committerSam James <sam@gentoo.org>2021-03-16 21:31:35 +0000
commit316fc4bd83663708a147d9e58a6f2ee156e9d0a7 (patch)
treebf9958f98f2ff3127d7975b2a03c2ef3af008294 /app-misc
parentmedia-gfx/graphicsmagick: add myself to maintainers (and codec@) (diff)
downloadgentoo-316fc4bd83663708a147d9e58a6f2ee156e9d0a7.tar.gz
gentoo-316fc4bd83663708a147d9e58a6f2ee156e9d0a7.tar.bz2
gentoo-316fc4bd83663708a147d9e58a6f2ee156e9d0a7.zip
app-misc/wipe: update EAPI 6 -> 7, musl patch
Closes: https://bugs.gentoo.org/713622 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch21
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild13
2 files changed, 27 insertions, 7 deletions
diff --git a/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch b/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch
new file mode 100644
index 000000000000..f14c77e09766
--- /dev/null
+++ b/app-misc/wipe/files/wipe-2.3.1-musl-stdint.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/713622
+--- a/rand.h
++++ b/rand.h
+@@ -20,15 +20,9 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#ifdef HAVE_STDINT_H
+-# include "stdint.h"
+-#else
+-# ifndef LINUX
+-# define u_int32_t uint32_t
+-# endif
+-#endif
++#include <stdint.h>
+
+-typedef u_int32_t u_rand_t;
++typedef uint32_t u_rand_t;
+
+ #ifndef UINT32_MAX
+ # define UINT32_MAX ULONG_MAX
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
index 8775ae458c90..2fd02b71399c 100644
--- a/app-misc/wipe/wipe-2.3.1.ebuild
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -12,12 +12,11 @@ SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-2.3.1-musl-stdint.patch
+)
src_prepare() {
default