summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-04-18 15:34:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-23 09:25:03 +0300
commit36b227da7b2fa83f3875e593939c388f466dc0b5 (patch)
treea1cdc49f1c51c90223edd2c40ff67f1924ac3891 /app-misc
parentdev-util/conan: drop 1.36.0 (diff)
downloadgentoo-36b227da7b2fa83f3875e593939c388f466dc0b5.tar.gz
gentoo-36b227da7b2fa83f3875e593939c388f466dc0b5.tar.bz2
gentoo-36b227da7b2fa83f3875e593939c388f466dc0b5.zip
app-misc/inputlircd: EAPI8 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/25090 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild
new file mode 100644
index 000000000000..b262f5a39eba
--- /dev/null
+++ b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
+HOMEPAGE="https://github.com/gsliepen/inputlirc"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ local ver="$(best_version sys-kernel/linux-headers)"
+ ver=${ver#sys-kernel/linux-headers-}
+ if ver_test 4.4 -ge ${ver}; then
+ eapply "${FILESDIR}/inputlircd-linux-4.4-fix.patch"
+ fi
+
+ sed -e 's|$(CFLAGS)|$(CFLAGS) $(LDFLAGS)|' -i Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
+ newconfd "${FILESDIR}"/inputlircd.conf inputlircd
+}