summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2022-02-27 16:36:44 +0100
committerPatrice Clement <monsieurp@gentoo.org>2022-02-27 16:36:44 +0100
commit386be6c482ced7456437f6f99e784e4446cd928d (patch)
tree58d5762aecef9de9e52e43f3b210d30d39608144 /app-misc
parentapp-misc/i2bits: drop 0.1.0 (diff)
downloadgentoo-386be6c482ced7456437f6f99e784e4446cd928d.tar.gz
gentoo-386be6c482ced7456437f6f99e784e4446cd928d.tar.bz2
gentoo-386be6c482ced7456437f6f99e784e4446cd928d.zip
app-misc/vifm: add 0.12
Closes: https://bugs.gentoo.org/834126 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/vifm/Manifest1
-rw-r--r--app-misc/vifm/vifm-0.12.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/vifm/Manifest b/app-misc/vifm/Manifest
index 32d132f9f552..ad487eb528c3 100644
--- a/app-misc/vifm/Manifest
+++ b/app-misc/vifm/Manifest
@@ -1 +1,2 @@
DIST vifm-0.11.tar.gz 1525791 BLAKE2B c2aa6d3ddd0304ce1e3a0d1c9ac3218a783bc6dd8eebf7b3346ca262811f63dac75597913ad4883c62680cb77036c2985ca4ce88989a0dd0212dce975d8ec8b8 SHA512 15ace460da6d5f9bb7a016d8bb3f3d9cba47a608da5a39defbf7d09ff9de64c90a63a44264d695fe005f2f6d27ecb07dcec8f4ed5aef15e9d8728b52f1168dbd
+DIST vifm-0.12.tar.gz 1913398 BLAKE2B 6a1933e5a70a61402ae52259ee9e03515916e9d6df57285726ec6062257d85966a32173142e730fbc35b48250c585a5e66cadba788e2029e5dcd620544341c4f SHA512 9491b1932535daa0ce6bd33ef955bfaedf995da27f049b36bdb0de9aa87a9a4dd6d2e22c8bf79e343febee16ae0fb87edfa8bde9c2d115b92c768e87bc0a8a7d
diff --git a/app-misc/vifm/vifm-0.12.ebuild b/app-misc/vifm/vifm-0.12.ebuild
new file mode 100644
index 000000000000..7ad0e2c512ff
--- /dev/null
+++ b/app-misc/vifm/vifm-0.12.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools vim-doc xdg
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="https://vifm.info/"
+SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="developer +extended-keys gtk +magic +vim +vim-syntax X"
+
+DEPEND="
+ >=sys-libs/ncurses-5.9-r3:0
+ magic? ( sys-apps/file )
+ gtk? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libX11 )"
+
+RDEPEND="${DEPEND}
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable developer) \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic) \
+ $(use_with gtk) \
+ $(use_with X X11)
+}
+
+src_install() {
+ default
+
+ if use vim; then
+ local t
+ for t in app plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins -r data/vim/doc/${t}/${PN}*
+ done
+ fi
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins -r data/vim/${t}/${PN}*
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if use vim; then
+ update_vim_helptags
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You don't need to copy or link any files for"
+ elog " the vim plugin and documentation to work anymore."
+ elog "If you copied any vifm files to ~/.vim/ manually"
+ elog " in earlier vifm versions, please delete them."
+ fi
+ elog
+ elog "To use vim in vifm to view the documentation"
+ elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ use vim && update_vim_helptags
+}