summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-19 19:30:50 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-19 19:30:50 +0100
commit527d1b89fcb4ec0805d897bddface002e19f044e (patch)
treec463f3c30068146b42a119d92953e987d036b410 /app-misc
parentapp-emacs/evil: Version bump. (diff)
downloadgentoo-527d1b89fcb4ec0805d897bddface002e19f044e.tar.gz
gentoo-527d1b89fcb4ec0805d897bddface002e19f044e.tar.bz2
gentoo-527d1b89fcb4ec0805d897bddface002e19f044e.zip
app-misc/go-jira: Version bump to 1.0.15
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/go-jira/Manifest1
-rw-r--r--app-misc/go-jira/go-jira-1.0.15.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/go-jira/Manifest b/app-misc/go-jira/Manifest
index 08cd704f4aa0..660bc7e3df67 100644
--- a/app-misc/go-jira/Manifest
+++ b/app-misc/go-jira/Manifest
@@ -1,2 +1,3 @@
DIST go-jira-1.0.12.tar.gz 1296394 BLAKE2B 9f693fbaf1c2e4463a98b08b545646f0ac4780403f6b98f5218066eee8be8345c23389373c28aed160d8cea974f207b6a141cd031eb88e6a726e286bdc3f062d SHA512 d777544253920691b2802c3cc0651b908501660365e4a991713d85cbc10e8f4c319056b91926cf6b06c13682ee160747834a82898b269aa7e10d87981066633e
DIST go-jira-1.0.14.tar.gz 1378174 BLAKE2B 119c40878eac9c6af2b7f17a914821110f40af3d5cb9b3f3783ba2c5c781314d0c76e5a0573c74e69e298f086d876b97ca7538828cbbf845f42e5874550beb7b SHA512 f9fc43adfb8c09f80307a39d2d169c4e4b537f64fbca5b7d355178125aa315cd6de9147b00b03a80218cb685ce02a0e0156cd902277367122aaa00c395c6f880
+DIST go-jira-1.0.15.tar.gz 1381623 BLAKE2B 430451fc6f86c72421619433427694f4a7a756c24cbd239c38ddcfb8b35a83215377bb239af43ceff90da1a9122d312190b8185dc5e04032a50491c8f61d9c2f SHA512 e4ceae1577ad8f512a9375775308687e78a50131faa298ba1cddc8397a8a04feca55f132c022d942458e8cab68f28e5610bf4b3334fe2c16f71e924e290ee955
diff --git a/app-misc/go-jira/go-jira-1.0.15.ebuild b/app-misc/go-jira/go-jira-1.0.15.ebuild
new file mode 100644
index 000000000000..80c476f47f72
--- /dev/null
+++ b/app-misc/go-jira/go-jira-1.0.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="gopkg.in/Netflix-Skunkworks/go-jira.v1"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A simple JIRA commandline client in Go"
+HOMEPAGE="https://github.com/Netflix-Skunkworks/go-jira"
+SRC_URI="https://github.com/Netflix-Skunkworks/go-jira/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${WORKDIR}/${P}" go build -v -o jira cmd/jira/main.go || die
+ popd || die
+}
+
+src_install() {
+ dobin src/${EGO_PN}/jira
+ dodoc src/${EGO_PN}/{CHANGELOG,README}.md
+}