summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-20 21:55:06 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-23 00:17:04 +0200
commit578ade4bbcb362c7f0002843db48747a4da0f0c5 (patch)
tree1d1386f78a49a049cc5e104d2cef2e23eb1a3e97 /app-misc
parentapp-misc/cdircmp: fix SRC_URI. (diff)
downloadgentoo-578ade4bbcb362c7f0002843db48747a4da0f0c5.tar.gz
gentoo-578ade4bbcb362c7f0002843db48747a4da0f0c5.tar.bz2
gentoo-578ade4bbcb362c7f0002843db48747a4da0f0c5.zip
app-misc/cdircmp: EAPI7, improve ebuild.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cdircmp/cdircmp-0.3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/cdircmp/cdircmp-0.3-r2.ebuild b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
new file mode 100644
index 000000000000..ea5818e44538
--- /dev/null
+++ b/app-misc/cdircmp/cdircmp-0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compare directories and select files to copy"
+HOMEPAGE="http://home.hccnet.nl/paul.schuurmans/"
+SRC_URI="http://home.hccnet.nl/paul.schuurmans/linux/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.4:0="
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+}