summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerb Miller Jr <herb@hlmjr.com>2018-03-03 19:19:58 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-24 20:39:42 +0100
commit5813c61666a019002f48fe95459bd12f61270f97 (patch)
tree8861fa367a2aa066049da0ed3ea4bb97d1b1f50f /app-misc
parentapp-misc/gramps: Add postscript USE flag. (diff)
downloadgentoo-5813c61666a019002f48fe95459bd12f61270f97.tar.gz
gentoo-5813c61666a019002f48fe95459bd12f61270f97.tar.bz2
gentoo-5813c61666a019002f48fe95459bd12f61270f97.zip
app-misc/gramps: Fix MimeType QA notice.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gramps/gramps-4.2.8.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-misc/gramps/gramps-4.2.8.ebuild b/app-misc/gramps/gramps-4.2.8.ebuild
index 8b6fa4bcdefc..556bb44410a6 100644
--- a/app-misc/gramps/gramps-4.2.8.ebuild
+++ b/app-misc/gramps/gramps-4.2.8.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python3_{4,5} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1
+inherit distutils-r1 xdg-utils
DESCRIPTION="Genealogical Research and Analysis Management Programming System"
HOMEPAGE="https://gramps-project.org/"
@@ -44,3 +44,13 @@ python_prepare_all() {
sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
distutils-r1_python_prepare_all
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}