summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2022-04-14 21:59:39 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2022-04-14 21:59:51 -0700
commit76f55948553c4a00bebea7334608cd16a686398e (patch)
tree21d1a5b1a30d757b25f9721949e1e538f763226f /app-misc
parentsys-block/fio: bump (diff)
downloadgentoo-76f55948553c4a00bebea7334608cd16a686398e.tar.gz
gentoo-76f55948553c4a00bebea7334608cd16a686398e.tar.bz2
gentoo-76f55948553c4a00bebea7334608cd16a686398e.zip
app-misc/ddcutil: cleanup
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/787020
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddcutil/Manifest1
-rw-r--r--app-misc/ddcutil/ddcutil-0.9.9-r3.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
index 36814e6355bf..6237ee274ea6 100644
--- a/app-misc/ddcutil/Manifest
+++ b/app-misc/ddcutil/Manifest
@@ -1,2 +1 @@
-DIST ddcutil-0.9.9.tar.gz 725207 BLAKE2B ad7b0b35ad4c2dae21da066e4194209579d774ded10f2dc0d8d7d3d94e70d5893c3d1f772b86ea01be510cfb8d51a657178228d028ca34ab20d344e86e0581d2 SHA512 f7b2b961c6b76ef59f336290b494cdd331556848de881d57e5240075d50733030df4c47131070f1276907d712a45f60dad6bebaa052a66621b8b5517ff293c21
DIST ddcutil-1.2.2.tar.gz 803943 BLAKE2B 65cc5dc0d1ee85d1e2b6670f7c24508ab817c6eebdb596b5f6f70c7ff7b9257f12f70abfea2d735e23755e508d4829d4be6574ac16564d4d828e0b1153cf8afe SHA512 0329711e536cbcaee2efe6cf981a17181ab318846e9c6a82f2ceacc42691ba49c06df44a52d1f079568e9ccec588cc85d4de4adf19b6db83bebe4bb90ae29207
diff --git a/app-misc/ddcutil/ddcutil-0.9.9-r3.ebuild b/app-misc/ddcutil/ddcutil-0.9.9-r3.ebuild
deleted file mode 100644
index 53bf5448e893..000000000000
--- a/app-misc/ddcutil/ddcutil-0.9.9-r3.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic linux-info udev
-
-DESCRIPTION="Program for querying and changing monitor settings"
-HOMEPAGE="http://www.ddcutil.com/"
-SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0/3"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="drm introspection usb-monitor user-permissions video_cards_nvidia X"
-REQUIRED_USE="drm? ( X )"
-
-RDEPEND="
- dev-libs/glib:2
- sys-apps/i2c-tools
- virtual/udev
- drm? ( x11-libs/libdrm )
- introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
- usb-monitor? (
- dev-libs/hidapi
- virtual/libusb:1
- sys-apps/usbutils
- )
- user-permissions? (
- acct-group/i2c
- usb-monitor? ( acct-group/video )
- )
- X? (
- x11-libs/libXrandr
- x11-libs/libX11
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-pkg_pretend() {
- # This program needs /dev/ic2-* devices to communicate with the monitor.
- CONFIG_CHECK="~I2C_CHARDEV"
- ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
- if use usb-monitor; then
- CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
- ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
- ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
- fi
-
- # Now do the actual checks setup above
- check_extra_config
-}
-
-src_prepare() {
- default
- eautoreconf
- sed -e "s#usr/local/bin#usr/bin#" -i data/etc/udev/rules.d/45-ddcutil-usb.rules || die
-}
-
-src_configure() {
- # Bug 607818.
- replace-flags -O3 -O2
-
- local myeconfargs=(
- $(use_enable drm)
- $(use_enable usb-monitor usb)
- $(use_enable X x11)
- --enable-lib
- # Please read upstream's note about the original purpose of these flags before re-enabling them:
- # https://github.com/rockowitz/ddcutil/issues/128
- # As of 0.9.9 the following no longer compile:
- # Python3 & CFFI is already broken as of Python 3.7, with future removal;
- # SWIG : Python3.7 breakage as well PyFileObject vs PyCodeObject
- --disable-cffi
- --disable-cython
- --disable-swig
- $(use_enable introspection)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- if use user-permissions; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
- if use usb-monitor; then
- udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
- fi
- fi
-}
-
-pkg_postinst() {
- if use user-permissions; then
- einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
- einfo "users to the i2c group: usermod -aG i2c user"
- einfo "Restart the computer or reload the i2c-dev module to activate"
- einfo "the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
-
- if use usb-monitor; then
- einfo "To allow non-root users access to USB monitors, add those users"
- einfo "to the video group: usermod -aG video user"
- einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
- einfo "the monitor to activate the new udev rule."
- einfo "For more information read: http://www.ddcutil.com/usb/"
- fi
-
- udev_reload
- fi
-
- if use video_cards_nvidia; then
- ewarn "Please read the following webpage on proper usage with the nVidia "
- ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
- fi
-}