summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-12-26 19:57:53 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-26 19:58:13 +0100
commit86ade5ab229085c7f6ba914b98105411998558e4 (patch)
treedfe4433aa04f45eb12a918e52896dd3e0f630aba /app-misc
parentx11-wm/evilwm: Adjust HOMEPAGE (diff)
downloadgentoo-86ade5ab229085c7f6ba914b98105411998558e4.tar.gz
gentoo-86ade5ab229085c7f6ba914b98105411998558e4.tar.bz2
gentoo-86ade5ab229085c7f6ba914b98105411998558e4.zip
app-misc/ondir: EAPI 6 bump.
Bug: https://bugs.gentoo.org/642166 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ondir/ondir-0.2.2-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/ondir/ondir-0.2.2-r2.ebuild b/app-misc/ondir/ondir-0.2.2-r2.ebuild
new file mode 100644
index 000000000000..d483901c75fa
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automatically execute scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh )
+HTML_DOCS=( changelog.html ondir.1.html )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ CONF="${EPREFIX}/etc/ondirrc" \
+ install
+ newdoc ondirrc.eg ondirrc.example
+}