summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-25 10:31:33 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-26 11:50:45 +0100
commit8a5d141841a74cc45ee84b384cad1ed42c518c8b (patch)
tree4a2b1a3ce8e11a573cf16443043a0ce5639ad9ce /app-misc
parentapp-crypt/libsecret: drop old revision (diff)
downloadgentoo-8a5d141841a74cc45ee84b384cad1ed42c518c8b.tar.gz
gentoo-8a5d141841a74cc45ee84b384cad1ed42c518c8b.tar.bz2
gentoo-8a5d141841a74cc45ee84b384cad1ed42c518c8b.zip
app-misc/gnote: fix X USE flag behavior
Package-Manager: portage-2.2.25
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/files/gnote-3.18.2-x11-support-switch.patch30
-rw-r--r--app-misc/gnote/gnote-3.18.0-r1.ebuild80
2 files changed, 110 insertions, 0 deletions
diff --git a/app-misc/gnote/files/gnote-3.18.2-x11-support-switch.patch b/app-misc/gnote/files/gnote-3.18.2-x11-support-switch.patch
new file mode 100644
index 000000000000..c1264697f67e
--- /dev/null
+++ b/app-misc/gnote/files/gnote-3.18.2-x11-support-switch.patch
@@ -0,0 +1,30 @@
+From f36016ae8352ecc7aba800fe3f2057c016d644df Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 25 Nov 2015 10:07:15 +0100
+Subject: [PATCH 1/2] Fix X11 support configure switch
+
+---
+ configure.ac | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 64a5e21..a28eb04 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -147,9 +147,11 @@ fi
+ AC_SUBST(DBUS_SERVICE_DIR)
+
+ AC_ARG_WITH(x11_support, [ --with-x11-support Compile with X11 support.],
+- [with_x11_support=yes;AC_DEFINE(HAVE_X11_SUPPORT, [1], [Define to 1 to include X11 support.])],
++ [],
+ [with_x11_support=no])
+-AM_CONDITIONAL(HAVE_X11_SUPPORT, test "x$with_x11_support" != "x")
++AS_IF([test "$with_x11_support" = "yes"],
++ [AC_DEFINE(HAVE_X11_SUPPORT, [1], [Define to 1 to include X11 support.])])
++AM_CONDITIONAL(HAVE_X11_SUPPORT, test "x$with_x11_support" = "xyes")
+
+
+ IT_PROG_INTLTOOL([0.35.0])
+--
+2.6.3
+
diff --git a/app-misc/gnote/gnote-3.18.0-r1.ebuild b/app-misc/gnote/gnote-3.18.0-r1.ebuild
new file mode 100644
index 000000000000..b8c8e82a2625
--- /dev/null
+++ b/app-misc/gnote/gnote-3.18.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 readme.gentoo
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug X"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.10:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.10:3
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix x11-support switch
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758636
+ epatch "${FILESDIR}"/${PN}-3.18.2-x11-support-switch.patch
+
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ eautoreconf
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with X x11-support)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}