summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-18 19:39:31 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-19 10:08:45 +0100
commit8da8c384cd38ccee44ec336d18ee12b7cb82a7ab (patch)
tree90c3581794f8d7a685e3534363f9ec6010c8c33a /app-misc
parentapp-emulation/qemu: amd64 stable wrt bug #649616 (diff)
downloadgentoo-8da8c384cd38ccee44ec336d18ee12b7cb82a7ab.tar.gz
gentoo-8da8c384cd38ccee44ec336d18ee12b7cb82a7ab.tar.bz2
gentoo-8da8c384cd38ccee44ec336d18ee12b7cb82a7ab.zip
app-misc/away: tidy up ebuild.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/away/away-0.9.5-r2.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/app-misc/away/away-0.9.5-r2.ebuild b/app-misc/away/away-0.9.5-r2.ebuild
index 2c5e59eac8d1..36184acaa9af 100644
--- a/app-misc/away/away-0.9.5-r2.ebuild
+++ b/app-misc/away/away-0.9.5-r2.ebuild
@@ -7,35 +7,33 @@ inherit pam toolchain-funcs flag-o-matic
DESCRIPTION="Terminal locking program with few additional features"
HOMEPAGE="http://unbeatenpath.net/software/away/"
-SRC_URI="http://unbeatenpath.net/software/away/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 sparc x86"
-IUSE=""
RDEPEND=">=sys-libs/pam-0.75"
DEPEND="${RDEPEND}"
+DOCS=( BUGS AUTHORS NEWS README TODO data/awayrc )
src_prepare() {
default
sed -i -e '/-o \$(BINARY)/d' \
- -e 's:LIBS:LDLIBS:' \
- "${S}"/Makefile || die "Makefile fix failed"
+ -e 's:LIBS:LDLIBS:' \
+ "${S}"/Makefile || die "Makefile fix failed"
}
src_compile() {
append-flags -pthread
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
}
src_install() {
dobin away
-
- pamd_mimic_system away auth
-
doman doc/*
- dodoc BUGS AUTHORS NEWS README TODO data/awayrc
+ einstalldocs
+ pamd_mimic_system away auth
}