summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-31 12:36:50 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-31 12:36:59 -0700
commit936f9af6ded55fccbaa72cba829766c20853bd03 (patch)
tree2f93334fc7229380406e5f8a236345eafb4844ab /app-misc
parentapp-text/blogc: version bump (diff)
downloadgentoo-936f9af6ded55fccbaa72cba829766c20853bd03.tar.gz
gentoo-936f9af6ded55fccbaa72cba829766c20853bd03.tar.bz2
gentoo-936f9af6ded55fccbaa72cba829766c20853bd03.zip
app-misc/icdiff-1.9.5: Version bump (bug #713096)
Closes: https://bugs.gentoo.org/713096 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/icdiff/Manifest1
-rw-r--r--app-misc/icdiff/files/icdiff-1.9.5-tests.patch29
-rw-r--r--app-misc/icdiff/icdiff-1.9.5.ebuild28
3 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/icdiff/Manifest b/app-misc/icdiff/Manifest
index 868fbc3812a3..bbdd5ae7dfaa 100644
--- a/app-misc/icdiff/Manifest
+++ b/app-misc/icdiff/Manifest
@@ -1 +1,2 @@
DIST icdiff-1.9.1.tar.gz 24387 BLAKE2B 482b128f03ac8af7e98db9b32ba7d9cf8bcd1a395eb50653a98ac186da26fea7933ee13f01840bb6c105e0f573a519a3e20ad83fbd8e513bfdd6c8c6d14b90c5 SHA512 f73108f6f3a4a2fc40e041bbe7b5934acd76684bb54a3fa544e9f146fd3c528528928378496f53ad92d649547ccc491a77296b6fa57e4534abb13d61c0df8d58
+DIST icdiff-1.9.5.tar.gz 31914 BLAKE2B 8d9b9b5104c3075addae2954b41c27ccebe3b4723b0e71ef88a214d7fa0ff7d8cb9ac52cada8ddec929d308a356daf37ef4463a52667f7e229a4a33d1d993e86 SHA512 f4c50da1e73a1af2fd63feabfd180125637a856a8757356eb3b48bbc21871f36a2c876acd2e2ba9d354c8f6e658f6e262fbbfd65fa4078d0adebc1353d87e40a
diff --git a/app-misc/icdiff/files/icdiff-1.9.5-tests.patch b/app-misc/icdiff/files/icdiff-1.9.5-tests.patch
new file mode 100644
index 000000000000..3e2467460d2c
--- /dev/null
+++ b/app-misc/icdiff/files/icdiff-1.9.5-tests.patch
@@ -0,0 +1,29 @@
+diff --git a/test.sh b/test.sh
+index fd1679e..5b756f3 100755
+--- a/test.sh
++++ b/test.sh
+@@ -86,6 +86,8 @@ function check_git_diff() {
+ local gitdiff=tests/$1
+ shift
+
++ # does not work with newer versions of git
++ if false; then
+ echo " check_gitdiff $gitdiff matches git icdiff $@"
+ # Check when using icdiff in git
+ if $FIRST_TIME_CHECK_GIT_DIFF; then
+@@ -96,13 +98,14 @@ function check_git_diff() {
+ export PATH=$PATH:"$(pwd)"
+ fi
+ local tmp=/tmp/git-icdiff.output
+- git icdiff $1 $2 &> $tmp
++ git icdiff --no-index $1 $2 &> $tmp
+ if ! diff $tmp $gitdiff; then
+ echo "Got: ($tmp)"
+ cat $tmp
+ echo "Expected: ($gitdiff)"
+ fail
+ fi
++ fi
+ }
+
+ check_gold gold-recursive.txt --recursive tests/{a,b} --cols=80
diff --git a/app-misc/icdiff/icdiff-1.9.5.ebuild b/app-misc/icdiff/icdiff-1.9.5.ebuild
new file mode 100644
index 000000000000..1b4fa11ae9d1
--- /dev/null
+++ b/app-misc/icdiff/icdiff-1.9.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="https://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/icdiff-1.9.5-tests.patch"
+)
+
+DOCS=(README.md ChangeLog)
+
+python_test() {
+ bash test.sh "${EPYTHON%.*}" || die "Tests failed with ${EPYTHON}"
+}