summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-06-20 13:17:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2019-06-20 13:26:35 +0000
commit993ef0de780a19cc7f973407032ada2054b38108 (patch)
tree4644a4df1c6576c556987b4e185d8839616f7c02 /app-misc
parentdev-tex/latex-beamer: Version bump (v3.55) (diff)
downloadgentoo-993ef0de780a19cc7f973407032ada2054b38108.tar.gz
gentoo-993ef0de780a19cc7f973407032ada2054b38108.tar.bz2
gentoo-993ef0de780a19cc7f973407032ada2054b38108.zip
app-misc/anki: Bump
Fix #652000 Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/Manifest1
-rw-r--r--app-misc/anki/anki-2.1.13.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-misc/anki/Manifest b/app-misc/anki/Manifest
index 28261ed76b86..2f3e3983b2e0 100644
--- a/app-misc/anki/Manifest
+++ b/app-misc/anki/Manifest
@@ -1,2 +1,3 @@
DIST anki-2.1.0_beta25.tgz 4117303 BLAKE2B 0f7021c4da4efa918c285fa6bf85242e52999d0f340d4a882651cf1e2857ac015f6f99967d4a7fee6df92a2b3c4849eb838707b08abd04d534f4d21ce28eb749 SHA512 9ddf984c575df00fe9b7974f24166a0f18d63e904b3d9bd4370de506828a251efed0fb319f06dc23c6852aae46e552994c6633880603a6e746d4d242b9e627f8
DIST anki-2.1.0_beta27.tgz 4127906 BLAKE2B b4f83cc30dc3e89f3ca17c03ba8dcfc9a487de43d8ac564d5dc83488e286c302816c8a8140aa764b596404194c5f3727218deec303ef201ccaef38b945d8b32d SHA512 50b4ece1361ecafdfe08dad04e9b622b1e8ba2224bfef7e4660c95f81cb8f525d892170548d741ff53bc19ff4c13863f488a71c31c8328511fea3203d2c345f1
+DIST anki-2.1.13.tgz 4248906 BLAKE2B 82a2a9a556cbf3596af22a73a2865815561cdd408b249443fc7e144734fdc2b62317120db71475afd7b0d4027f19e53c47437132028ef78b158ec3624f54a33f SHA512 921ef48b16c0c8c83b85523aa0a5b828210b210cd51fa471f57e9aa6777a1aced30c7e24084ef0c2f14c9d846a19091923d13faaff7ed9075860fc23f8ba1cd3
diff --git a/app-misc/anki/anki-2.1.13.ebuild b/app-misc/anki/anki-2.1.13.ebuild
new file mode 100644
index 000000000000..bb38a02500c9
--- /dev/null
+++ b/app-misc/anki/anki-2.1.13.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils python-single-r1 xdg
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="https://apps.ankiweb.net"
+SRC_URI="https://apps.ankiweb.net/downloads/current/${P}-source.tgz -> ${P}.tgz"
+
+S="${WORKDIR}/${P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/PyQt5[gui,svg,webengine,widgets,${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ recording? ( media-sound/lame )
+ sound? ( media-video/mpv )
+ latex? (
+ app-text/texlive
+ app-text/dvipng
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/updates=True/updates=False/" \
+ aqt/profiles.py || die
+}
+
+src_compile() {
+ :;
+}
+
+src_test() {
+ sed -e "s:nose=nosetests$:nose=\"${EPYTHON} ${EROOT}usr/bin/nosetests\":" \
+ -i tools/tests.sh || die
+ sed -e "s:nose=nosetests3$:nose=\"${EPYTHON} ${EROOT}usr/bin/nosetests3\":" \
+ -i tools/tests.sh || die
+ sed -e "s:which nosetests3:which ${EROOT}usr/bin/nosetests3:" \
+ -i tools/tests.sh || die
+ ./tools/tests.sh || die
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README.md README.development
+ python_domodule aqt anki
+ python_newscript runanki anki
+
+ # Localization files go into the anki directory:
+ python_moduleinto anki
+ python_domodule locale
+
+ # not sure if this is correct, but
+ # site-packages/aqt/mediasrv.py wants the directory
+ insinto /usr/share/anki
+ doins -r web
+}