summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-29 15:44:04 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-29 16:01:45 +0100
commita30d23cd4566b356e8e6cd6d17350ad30764af87 (patch)
treef776a40db057bc12686c43dc11fde976d28a1588 /app-misc
parentapp-office/libreoffice-bin-debug: Version bump (diff)
downloadgentoo-a30d23cd4566b356e8e6cd6d17350ad30764af87.tar.gz
gentoo-a30d23cd4566b356e8e6cd6d17350ad30764af87.tar.bz2
gentoo-a30d23cd4566b356e8e6cd6d17350ad30764af87.zip
app-misc/mc: Revbump to add "unicode" USE flag.
This is necessary to prevent segfaults with USE="-slang" and sys-libs/ncurses being built with USE="unicode". Further changes: - use myeconfargs bash array for configure options - replaced some local configure variables with usex calls - sorted all configure options alphabetically - added pkg_pretend() to inform users about USE="slang unicode" having no effect. - removed superfluous eutils eclass. Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/mc-4.8.20-r2.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/app-misc/mc/mc-4.8.20-r2.ebuild b/app-misc/mc/mc-4.8.20-r2.ebuild
new file mode 100644
index 000000000000..26a9982ce6a5
--- /dev/null
+++ b/app-misc/mc/mc-4.8.20-r2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://www.midnight-commander.org"
+SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm mclib nls samba sftp +slang spell test X +xdg unicode"
+
+REQUIRED_USE="spell? ( edit )"
+
+RDEPEND=">=dev-libs/glib-2.26.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:0=[unicode?] )
+ spell? ( app-text/aspell )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.13-tinfo.patch
+ "${FILESDIR}"/${PN}-4.8.19-selected-size.patch
+)
+
+S=${WORKDIR}/${MY_P}
+
+pkg_pretend() {
+ if use slang && use unicode ; then
+ ewarn "\"unicode\" USE flag only takes effect when the \"slang\" USE flag is disabled."
+ fi
+}
+
+src_prepare() {
+ [[ -n ${LIVE_EBUILD} ]] && ./autogen.sh
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --disable-silent-rules
+ --enable-charset
+ --enable-vfs
+ --with-homedir=$(usex xdg 'XDG' '.mc')
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w')")
+ $(use_enable kernel_linux vfs-undelfs)
+ $(use_enable mclib)
+ $(use_enable nls)
+ $(use_enable samba vfs-smb)
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+
+ if ! use xdg ; then
+ sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
+ -i "${ED%/}"/usr/libexec/mc/ext.d/*.sh || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}