summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-27 22:44:24 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-27 23:10:25 +0100
commitaaaf921ea67d3347a4fe39ac620f5fd7d9d03941 (patch)
tree4023c13c3d6a193ff6fac59d36cd7f27ad497479 /app-misc
parentnet-im/telegram-desktop-bin: clean up old. (diff)
downloadgentoo-aaaf921ea67d3347a4fe39ac620f5fd7d9d03941.tar.gz
gentoo-aaaf921ea67d3347a4fe39ac620f5fd7d9d03941.tar.bz2
gentoo-aaaf921ea67d3347a4fe39ac620f5fd7d9d03941.zip
app-misc/wipe: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
index c53200bc8276..8775ae458c90 100644
--- a/app-misc/wipe/wipe-2.3.1.ebuild
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
HOMEPAGE="http://wipe.sourceforge.net/"
@@ -17,19 +17,23 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_compile() {
- emake CFLAGS="${CFLAGS}" || die
+ emake CFLAGS="${CFLAGS}"
}
src_install() {
- dobin wipe || die
- doman wipe.1 || die
- dodoc CHANGES README TODO TESTING || die
+ dobin wipe
+ doman wipe.1
+ einstalldocs
+ dodoc TESTING
}
pkg_postinst() {