summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-30 15:59:30 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-30 15:59:30 -0400
commitc002efa88949c23634b69992207c432354d2ef71 (patch)
tree8ab384d9f977460e3233f41343bdace1389152f1 /app-misc
parentapp-arch/gnome-autoar: Version bump to 0.3.2 (diff)
downloadgentoo-c002efa88949c23634b69992207c432354d2ef71.tar.gz
gentoo-c002efa88949c23634b69992207c432354d2ef71.tar.bz2
gentoo-c002efa88949c23634b69992207c432354d2ef71.zip
app-misc/bijiben: Version bump to 40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/bijiben/Manifest1
-rw-r--r--app-misc/bijiben/bijiben-40.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/bijiben/Manifest b/app-misc/bijiben/Manifest
index 09a11b1aa741..6af8dad6e827 100644
--- a/app-misc/bijiben/Manifest
+++ b/app-misc/bijiben/Manifest
@@ -1,2 +1,3 @@
DIST bijiben-3.36.3.tar.xz 528772 BLAKE2B 2445f0b3b40aa9c556635d25e85b31f620a83a4be4ed4c6d3091d3f3c5f19d5b8fc13769ed56bea6a731184b9dfdd2f604a3f29ad8dbde9c019a1f58f4c41447 SHA512 dba2d9da6ae62dd10a75662b9b04475e0ba64f50065d1dab8da8601b6a4dc44cb4f2b6129dec1f4a415844bee80ff534704e703118838a993a4ffe3ebbe2d254
DIST bijiben-40.0.tar.xz 642760 BLAKE2B 9c0f9f1d103e9775ce1369b16844828c11c2c43ba9808a5978d7090fe131d9dd54a25cd4fd06cb565b2d7936c6298a87f4a774cc5c30aa0cd6a86ae012b45043 SHA512 3fef381014109fe716d05b4b150f80778196c29af588e3a476b663aac5b113659f8ddfed82417811292bf9039a3d0982591503f72550130179ed1a7fef39edcd
+DIST bijiben-40.1.tar.xz 687344 BLAKE2B 187e6d0af40649ef35453af4ce51f286196bfd0570370136611cd2191e6c0c6b578e95eb4b6edf448bac6ae7b93b729afef161d3cd4d2cbd9c40f873ed5004c3 SHA512 5d2e0694f9eddca9a152eac5c208b51a15d2a5651ab77c79c1bb94425c0f1541c916887c3aab5fb8b105ca50d0f14c432ac18cd8ac64d03e2a0ee46c91901f10
diff --git a/app-misc/bijiben/bijiben-40.1.ebuild b/app-misc/bijiben/bijiben-40.1.ebuild
new file mode 100644
index 000000000000..6748c33e46a8
--- /dev/null
+++ b/app-misc/bijiben/bijiben-40.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Note editor designed to remain simple to use"
+HOMEPAGE="https://wiki.gnome.org/Apps/Notes"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-misc/tracker:3=
+ >=dev-libs/glib-2.53.4:2
+ net-libs/gnome-online-accounts:=
+ >=x11-libs/gtk+-3.19.3:3
+ dev-libs/json-glib
+ >=gnome-extra/evolution-data-server-3.33.2:=
+ >=gui-libs/libhandy-1.0.0:1=
+ dev-libs/libxml2:2
+ sys-apps/util-linux
+ >=net-libs/webkit-gtk-2.26:4
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dupdate_mimedb=false
+ -Dprivate_store=false # private store is mainly meant for flatpak builds
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}