summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-12-03 04:40:36 +0000
committerFlorian Schmaus <flow@gentoo.org>2023-12-13 08:59:36 +0100
commitd193b005ba4662a1198d805f40f9378ac9c18434 (patch)
tree5b9301a231fc68d581042272b61b5f43db779748 /app-misc
parentnet-irc/weechat: add 4.1.2 (diff)
downloadgentoo-d193b005ba4662a1198d805f40f9378ac9c18434.tar.gz
gentoo-d193b005ba4662a1198d805f40f9378ac9c18434.tar.bz2
gentoo-d193b005ba4662a1198d805f40f9378ac9c18434.zip
app-misc/hyfetch: add 1.4.11
Signed-off-by: Bailey Kasin <baileykasin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34101 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hyfetch/Manifest1
-rw-r--r--app-misc/hyfetch/hyfetch-1.4.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/hyfetch/Manifest b/app-misc/hyfetch/Manifest
index 3a5f627eff09..6828c0de92ea 100644
--- a/app-misc/hyfetch/Manifest
+++ b/app-misc/hyfetch/Manifest
@@ -1 +1,2 @@
DIST hyfetch-1.4.10.tar.gz 266471 BLAKE2B 294002c2cd986055f6392aa61bb8de1d3d558712cd327243e7c2e756aa6e00ff23372fd0ffcc60db8f978110a3d8d1d78c6f683e304fc65b19d2f076e10347f2 SHA512 3f44bd9c0b030b435949db0c0cbd4913e7ec15e857df0dcf2fc3b7d10dca0a4c8ecb9862157f60eebd15b7a1c233c51a74f341b440892e0925871e42215c80e0
+DIST hyfetch-1.4.11.tar.gz 275741 BLAKE2B 0739dc7bc2a90989dcd4dbdd6d14ce8ba62def2a9e069ae16a3a1435118e3639edcc112fc3fa0b8dd54684744e500672c7397315b78d965b68da2f9b9f702b13 SHA512 13c757fed68c9aa1caa503553d6d29c0b68284029090b970b863dec3240dabb28a852ef0ec0f2742c6c268e30a15c48018a651e74ba0e6782b5aa14f2b1d1312
diff --git a/app-misc/hyfetch/hyfetch-1.4.11.ebuild b/app-misc/hyfetch/hyfetch-1.4.11.ebuild
new file mode 100644
index 000000000000..5f65e10006ae
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-1.4.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}