summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 10:09:32 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 10:09:32 +0200
commitd2e84cfb1ab1b95a512c6d489f9e9d70253ae416 (patch)
tree3db222e7b231b82ab93086788cad3b55ecb79a18 /app-misc
parentmedia-gfx/replicatorg: Fix leading whitespaces (diff)
downloadgentoo-d2e84cfb1ab1b95a512c6d489f9e9d70253ae416.tar.gz
gentoo-d2e84cfb1ab1b95a512c6d489f9e9d70253ae416.tar.bz2
gentoo-d2e84cfb1ab1b95a512c6d489f9e9d70253ae416.zip
app-misc/xmind: QA fixes
Fix leading whitespaces Unnecessary die Unecessary dodir Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xmind/xmind-3.4.1.201401221918.ebuild13
-rw-r--r--app-misc/xmind/xmind-3.5.1.201411201906.ebuild11
-rw-r--r--app-misc/xmind/xmind-3.5.3.201506180105.ebuild11
3 files changed, 19 insertions, 16 deletions
diff --git a/app-misc/xmind/xmind-3.4.1.201401221918.ebuild b/app-misc/xmind/xmind-3.4.1.201401221918.ebuild
index 252f66de4ca8..7fd52347451a 100644
--- a/app-misc/xmind/xmind-3.4.1.201401221918.ebuild
+++ b/app-misc/xmind/xmind-3.4.1.201401221918.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -43,11 +43,13 @@ src_configure() {
mv XMind/.eclipseproduct Commons || die
cp "${FILESDIR}"/${PN}-3.4.0-config.ini Commons/configuration || die #Combined common+linux config.ini
# force data instance & config area to be at home/.xmind directory
- sed -i -e '/-configuration/d' \
+ sed \
+ -e '/-configuration/d' \
-e '/\.\/configuration/d' \
-e '/-data/d' \
- -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
- -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' XMind/XMind.ini || die
+ -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
+ -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' \
+ -i XMind/XMind.ini || die
echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/XMind.ini || die
echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/XMind.ini || die
}
@@ -58,10 +60,9 @@ src_compile() {
src_install() {
insinto /opt/xmind
- doins -r Commons XMind || die
+ doins -r Commons XMind
fperms a+rx "/opt/xmind/XMind/XMind"
- dodir /opt/bin
exeinto /opt/bin
newexe "${FILESDIR}/xmind-wrapper" xmind
diff --git a/app-misc/xmind/xmind-3.5.1.201411201906.ebuild b/app-misc/xmind/xmind-3.5.1.201411201906.ebuild
index 4a1c82e474d9..0dcc285605d4 100644
--- a/app-misc/xmind/xmind-3.5.1.201411201906.ebuild
+++ b/app-misc/xmind/xmind-3.5.1.201411201906.ebuild
@@ -43,11 +43,13 @@ src_configure() {
mv XMind/.eclipseproduct Commons || die
cp "${FILESDIR}"/${PN}-3.4.0-config.ini Commons/configuration || die #Combined common+linux config.ini
# force data instance & config area to be at home/.xmind directory
- sed -i -e '/-configuration/d' \
+ sed \
+ -e '/-configuration/d' \
-e '/\.\/configuration/d' \
-e '/-data/d' \
- -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
- -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' XMind/XMind.ini || die
+ -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
+ -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' \
+ -i XMind/XMind.ini || die
echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/XMind.ini || die
echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/XMind.ini || die
}
@@ -58,10 +60,9 @@ src_compile() {
src_install() {
insinto /opt/xmind
- doins -r Commons XMind || die
+ doins -r Commons XMind
fperms a+rx "/opt/xmind/XMind/XMind"
- dodir /opt/bin
exeinto /opt/bin
newexe "${FILESDIR}/xmind-wrapper" xmind
diff --git a/app-misc/xmind/xmind-3.5.3.201506180105.ebuild b/app-misc/xmind/xmind-3.5.3.201506180105.ebuild
index 4a1c82e474d9..0dcc285605d4 100644
--- a/app-misc/xmind/xmind-3.5.3.201506180105.ebuild
+++ b/app-misc/xmind/xmind-3.5.3.201506180105.ebuild
@@ -43,11 +43,13 @@ src_configure() {
mv XMind/.eclipseproduct Commons || die
cp "${FILESDIR}"/${PN}-3.4.0-config.ini Commons/configuration || die #Combined common+linux config.ini
# force data instance & config area to be at home/.xmind directory
- sed -i -e '/-configuration/d' \
+ sed \
+ -e '/-configuration/d' \
-e '/\.\/configuration/d' \
-e '/-data/d' \
- -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
- -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' XMind/XMind.ini || die
+ -e '/\.\.\/Commons\/data\/workspace-cathy/d' \
+ -e 's/\.\.\/Commons/\/opt\/xmind\/Commons/g' \
+ -i XMind/XMind.ini || die
echo '-Dosgi.instance.area=@user.home/.xmind/workspace-cathy' >> XMind/XMind.ini || die
echo '-Dosgi.configuration.area=@user.home/.xmind/configuration-cathy' >> XMind/XMind.ini || die
}
@@ -58,10 +60,9 @@ src_compile() {
src_install() {
insinto /opt/xmind
- doins -r Commons XMind || die
+ doins -r Commons XMind
fperms a+rx "/opt/xmind/XMind/XMind"
- dodir /opt/bin
exeinto /opt/bin
newexe "${FILESDIR}/xmind-wrapper" xmind