summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-16 20:40:55 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-04-28 09:42:02 +0300
commitd4969ef6df5d723871f7de62174d2c3fd1b3c63d (patch)
tree242468febcceed429d373fd9d5fb4bea6e7421f2 /app-misc
parentwww-apps/radicale: drop eutils.eclass from 2.1.12 (diff)
downloadgentoo-d4969ef6df5d723871f7de62174d2c3fd1b3c63d.tar.gz
gentoo-d4969ef6df5d723871f7de62174d2c3fd1b3c63d.tar.bz2
gentoo-d4969ef6df5d723871f7de62174d2c3fd1b3c63d.zip
app-misc/neofetch: Use optfeature for runtime dependencies
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20413 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/neofetch/neofetch-7.1.0-r1.ebuild42
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild21
2 files changed, 51 insertions, 12 deletions
diff --git a/app-misc/neofetch/neofetch-7.1.0-r1.ebuild b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
new file mode 100644
index 000000000000..b0c0a070de9b
--- /dev/null
+++ b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature prefix
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~mips ~ppc64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index b5f654d39b3b..b0c0a070de9b 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit prefix
+inherit optfeature prefix
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
@@ -17,17 +17,6 @@ DESCRIPTION="Simple information system script"
HOMEPAGE="https://github.com/dylanaraps/neofetch"
LICENSE="MIT-with-advertising"
SLOT="0"
-IUSE="X"
-
-RDEPEND="sys-apps/pciutils
- X? (
- media-gfx/imagemagick
- media-libs/imlib2
- www-client/w3m[imlib]
- x11-apps/xprop
- x11-apps/xrandr
- x11-apps/xwininfo
- )"
src_prepare() {
if use prefix; then
@@ -43,3 +32,11 @@ src_prepare() {
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}