summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-03 00:24:24 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-03 00:24:24 +0200
commitd9683b48d65a7e6b172161c504cb8d9da117d0e1 (patch)
treedd505e4df9d5d2eaf7b029dd16ee6d084042e170 /app-misc
parentdev-libs/libgdata: fix automagic gtk+ detection (diff)
downloadgentoo-d9683b48d65a7e6b172161c504cb8d9da117d0e1.tar.gz
gentoo-d9683b48d65a7e6b172161c504cb8d9da117d0e1.tar.bz2
gentoo-d9683b48d65a7e6b172161c504cb8d9da117d0e1.zip
app-misc/countrycodes: Port to EAPI6
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r2.ebuild34
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch6
2 files changed, 37 insertions, 3 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r2.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..b9140b6b2c8f
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${P}/src
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc ../doc/{Changelog,README}
+ prepman
+}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
index 4ee47e32dfd2..677e59acc5c0 100644
--- a/app-misc/countrycodes/files/1.0.5-Makefile.patch
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -1,7 +1,7 @@
-diff --git a/src/Makefile b/src/Makefile
+diff --git a/Makefile b/Makefile
index 9330578..3ff7319 100644
---- a/src/Makefile
-+++ b/src/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -26,13 +26,13 @@ BINMODE=755
LOGDIRMODE=700