summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2016-06-18 06:49:45 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2016-06-18 06:49:45 +0200
commite7f0867293e8e6ffb5368b7c0974adb779e1614f (patch)
tree9a4d28ffb9b22d45a8be26ab9cd8f791657f0bb2 /app-misc
parentmedia-tv/v4l-utils: clean up old (diff)
downloadgentoo-e7f0867293e8e6ffb5368b7c0974adb779e1614f.tar.gz
gentoo-e7f0867293e8e6ffb5368b7c0974adb779e1614f.tar.bz2
gentoo-e7f0867293e8e6ffb5368b7c0974adb779e1614f.zip
app-misc/boxes: Fix for Bug 586130
Thanks to Andreas Proteus <proteuss@sdf.lonestar.org> for the fix. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/boxes/boxes-1.1.2-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/boxes/boxes-1.1.2-r2.ebuild b/app-misc/boxes/boxes-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..7a8910e90d30
--- /dev/null
+++ b/app-misc/boxes/boxes-1.1.2-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="http://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_prepare() {
+ append-cflags -Iregexp -I. -ansi -std=c99
+ append-ldflags -Lregexp
+ sed \
+ -e 's:STRIP=true:STRIP=false:g' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/boxes
+ doman doc/boxes.1
+ dodoc README.md
+ insinto /usr/share
+ newins boxes-config boxes
+}