summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace@yandex.ru <ktrace@yandex.ru>2019-03-04 14:11:32 +0300
committerCraig Andrews <candrews@gentoo.org>2019-03-18 16:13:16 -0400
commitd65929ee791b56a4d3f947e745ae02e29191ff43 (patch)
treea27c0dbbc9eb1a835e3db11cf1343a4f47a74f95 /app-mobilephone/gammu
parentsys-apps/help2man: Removed old. (diff)
downloadgentoo-d65929ee791b56a4d3f947e745ae02e29191ff43.tar.gz
gentoo-d65929ee791b56a4d3f947e745ae02e29191ff43.tar.bz2
gentoo-d65929ee791b56a4d3f947e745ae02e29191ff43.zip
app-mobilephone/gammu: up to 1.40.0, EAPI=7
Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/11154 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11154 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/Manifest1
-rw-r--r--app-mobilephone/gammu/gammu-1.40.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/Manifest b/app-mobilephone/gammu/Manifest
index ac09a4322d6a..6e23505067db 100644
--- a/app-mobilephone/gammu/Manifest
+++ b/app-mobilephone/gammu/Manifest
@@ -1,2 +1,3 @@
DIST gammu-1.38.5.tar.bz2 2138742 BLAKE2B 7a72a7b67475f73dc3580d618dee379893dc82d7950599b41ed1f7efb5fecd80af3a42a0cc0742cb73d055a4a778eaa4d42037c5be74d9b61a4b53cfe827bd00 SHA512 89a6b3872dfd9b4ebaf8b0f51265fec7e7ef72a42178f85846c7f52d926e96b3087bbe6650c4246e66c2624822021c5803b1bb6ca8ac90f3e5c109a644c0ee80
DIST gammu-1.39.0.tar.bz2 2151226 BLAKE2B 0e9b7a3f5321a166bbafe833134f49ac8dc93a68c5522be1c16e5ceb894cb242b644761a90188fbc9fa9dd62bde51828a72b29d09fc37b2aa2911d301dffac39 SHA512 ed8994f6ec25d8ddbed23680e8a02db05c8e7f85aa6b8c0d409b5e8377e7c9e07fc61e62d80f6741d648709fb58a10ec631155d8b1ffc1c7d3b6e425cf53c797
+DIST gammu-1.40.0.tar.bz2 2156194 BLAKE2B b030e1293eaf1aeb38a553d45507ec2c3b4ba9ae34e7cb6589a60bd34451b545cc8e1f7bebfe28c9c1a12c89cecedeac17ffe27ddffab27c274590801b2091dc SHA512 6dbab68f30567a501487cf4edf19e23b7b23b7b78e3dfff69fc8d3c95b62f74ee14fe25ca380eac071e67f1a523dfd69cb9137fe049bf6477dfcc94930b71ce9
diff --git a/app-mobilephone/gammu/gammu-1.40.0.ebuild b/app-mobilephone/gammu/gammu-1.40.0.ebuild
new file mode 100644
index 000000000000..3eb015fdcee0
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.40.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A tool to handle your cellular phone"
+HOMEPAGE="https://wammu.eu/gammu/"
+SRC_URI="https://dl.cihar.com/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth curl dbi debug irda mysql nls odbc postgres usb"
+
+DEPEND="
+ dev-libs/glib:2=
+ virtual/libgudev:=
+ bluetooth? ( net-wireless/bluez:= )
+ curl? ( net-misc/curl:= )
+ dbi? ( >=dev-db/libdbi-0.8.3:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql:= )
+ usb? ( virtual/libusb:1= )
+"
+BDEPEND="
+ ${DEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-util/dialog
+ virtual/libiconv
+"
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_BLUETOOTH=$(usex bluetooth)
+ -DWITH_CURL=$(usex curl)
+ -DWITH_Gettext=$(usex nls)
+ -DWITH_Iconv=$(usex nls)
+ -DWITH_IRDA=$(usex irda)
+ -DWITH_LibDBI=$(usex dbi)
+ -DWITH_MySQL=$(usex mysql)
+ -DWITH_ODBC=$(usex odbc)
+ -DWITH_Postgres=$(usex postgres)
+ -DWITH_USB=$(usex usb)
+ -DBUILD_SHARED_LIBS=ON
+ -DINSTALL_DOC_DIR="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ addwrite "/run/lock/LCK..bar"
+ LD_LIBRARY_PATH="${BUILD_DIR}/libgammu" cmake-utils_src_test -j1
+}
+
+src_install() {
+ cmake-utils_src_install
+ docompress -x /usr/share/doc/${PF}/examples/
+}