summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild')
-rw-r--r--app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild
new file mode 100644
index 000000000000..d5178faa93bc
--- /dev/null
+++ b/app-mobilephone/gnome-phone-manager/gnome-phone-manager-0.69-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A program created to allow you to control aspects of your mobile phone from your GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/PhoneManager"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+# telepathy support is considered experimental
+
+RDEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2:2
+ >=gnome-extra/evolution-data-server-3.6:=
+ media-libs/libcanberra[gtk3]
+ >=app-mobilephone/gnokii-0.6.28[bluetooth]
+ net-wireless/bluez
+ dev-libs/dbus-glib
+ dev-libs/openobex
+ media-libs/libcanberra[gtk]
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=net-wireless/gnome-bluetooth-3.3:2
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+ gnome-base/gnome-common
+"
+# gnome-common needed for eautoreconf
+
+src_prepare() {
+ # Fix eds-3.6 building, upstream bug #680927
+ epatch "${FILESDIR}"/0001-Adapt-to-Evolution-Data-Server-API-changes.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bluetooth-plugin is no longer buildable, bug #512204
+ gnome2_src_configure \
+ --disable-bluetooth-plugin \
+ --disable-telepathy \
+ --disable-static
+}