summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-03 09:38:51 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-03 09:58:25 +0100
commit515f0865d762ee3b6f34aa65db85a91a8b1f3204 (patch)
treeb24cccf7cb69e91f454c9eeef7757a152fccb36a /app-mobilephone
parentapp-admin/ec2-ami-tools: use ruby21 with ruby-single eclass (diff)
downloadgentoo-515f0865d762ee3b6f34aa65db85a91a8b1f3204.tar.gz
gentoo-515f0865d762ee3b6f34aa65db85a91a8b1f3204.tar.bz2
gentoo-515f0865d762ee3b6f34aa65db85a91a8b1f3204.zip
app-mobilephone/obexftp: cleanup
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/obexftp-0.24.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-mobilephone/obexftp/obexftp-0.24.ebuild b/app-mobilephone/obexftp/obexftp-0.24.ebuild
deleted file mode 100644
index 4cdecc622c4b..000000000000
--- a/app-mobilephone/obexftp/obexftp-0.24.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit cmake-utils python-single-r1 python-utils-r1 eutils multilib
-
-DESCRIPTION="File transfer over OBEX for mobile phones"
-HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
-SRC_URI="mirror://sourceforge/openobex/${P}-Source.tar.gz"
-SLOT="0"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="bluetooth perl python ruby tcl"
-
-RDEPEND="
- >=dev-libs/openobex-1.7
- bluetooth? ( net-wireless/bluez )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="
- ${RDEPEND}
- perl? ( dev-lang/swig )
- python? ( dev-lang/swig )
- ruby? ( dev-lang/swig )
- tcl? ( dev-lang/swig )
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${P}-Source
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.23-gentoo.patch
- "${FILESDIR}"/${PN}-0.24-config.patch
- "${FILESDIR}"/${PN}-0.24-enable_bluetooth.patch
- "${FILESDIR}"/${PN}-0.24-python_sitedir.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PERL=$(usex perl)
- -DENABLE_BLUETOOTH=$(usex bluetooth)
- -DENABLE_PYTHON=$(usex python)
- $(usex python -DPYTHON_SITE_DIR=$(python_get_sitedir) '')
- -DENABLE_RUBY=$(usex ruby)
- -DENABLE_TCL=$(usex tcl)
- )
-
- cmake-utils_src_configure
-}