summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2020-09-03 12:09:10 -0600
committerDenis Dupeyron <calchan@gentoo.org>2020-09-03 12:09:49 -0600
commit5570aad5d2d8b3591dbc765030fce08ecbae0675 (patch)
treeafe9ee8c61a99e2a871c38c222c722cf0dcc2d19 /app-mobilephone
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.62 (diff)
downloadgentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.tar.gz
gentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.tar.bz2
gentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.zip
app-mobilephone/adb-sync: bump to 0_p20190101, add Python 3.8 (bug 738158)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/adb-sync/Manifest1
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
index 88d532a94d1f..f1d6c7bf13de 100644
--- a/app-mobilephone/adb-sync/Manifest
+++ b/app-mobilephone/adb-sync/Manifest
@@ -1 +1,2 @@
DIST adb-sync-0_p20181127.tar.gz 13952 BLAKE2B b9097f44eebd76e54cee41f097933f85151399e99275268274252b53f47ab241ecb888f3631dd9f657213160f02e9f3638d782fb24de8e38631d0e2a81b6b03e SHA512 007b9ec089170f3e679a26f23952043ad922a2f988532183200ddd15792858d4d38c6dbd617b32ff0e17d01b37b246c173e4a3f8c008f7cf4bca551e64cd0ca3
+DIST adb-sync-0_p20190101.tar.gz 13956 BLAKE2B 380109fa302fc5376de8124aa31c3fa03a27ece22d7f2d74638a5387820ad7c2b294daa6e8185f6eef49524e987d7a7f1222a1ee3b6550247993ebcc7c1ac98d SHA512 8bd5eb514c63327860017402f509231a0882cd3624ed3350039b2383f38e503abc6cd319ff41a47d70031958b0b38b973c36272fc4af6e69cce54e15e6bb6990
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 000000000000..9ad99a6a5711
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}