summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-01-22 13:33:32 +0100
committerPacho Ramos <pacho@gentoo.org>2017-01-22 13:39:07 +0100
commit05ae06abe7ed23cfc159b106ddc9f35e49d6233e (patch)
tree5fdd27cc719d3f0da453ec6ebe3b6937e7ab4ca0 /app-office/abiword/abiword-3.0.2-r1.ebuild
parentdev-libs/gmime: Version bump (diff)
downloadgentoo-05ae06abe7ed23cfc159b106ddc9f35e49d6233e.tar.gz
gentoo-05ae06abe7ed23cfc159b106ddc9f35e49d6233e.tar.bz2
gentoo-05ae06abe7ed23cfc159b106ddc9f35e49d6233e.zip
app-office/abiword: Fix regression with gtk+-3.22 (#601300), try to add references for all our applied patches.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-office/abiword/abiword-3.0.2-r1.ebuild')
-rw-r--r--app-office/abiword/abiword-3.0.2-r1.ebuild152
1 files changed, 152 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-3.0.2-r1.ebuild b/app-office/abiword/abiword-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..e02789f4774c
--- /dev/null
+++ b/app-office/abiword/abiword-3.0.2-r1.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="calendar collab cups debug eds +goffice grammar +introspection latex map math ots +plugins readline redland spell wordperfect wmf thesaurus"
+# You need 'plugins' enabled if want to enable the extra plugins
+REQUIRED_USE="!plugins? ( !collab !grammar !latex !math !ots !readline !thesaurus !wordperfect !wmf )"
+
+RDEPEND="
+ >=app-text/wv-1.2
+ >=dev-libs/fribidi-0.10.4
+ >=dev-libs/glib-2.16:2
+ >=dev-libs/libgcrypt-1.4.5:0=
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.16:2
+ >=gnome-extra/libgsf-1.14.18:=
+ >=media-libs/libpng-1.2:0=
+ virtual/jpeg:0
+ >=x11-libs/cairo-1.10[X]
+ >=x11-libs/gtk+-3.0.8:3[cups?]
+ calendar? ( >=dev-libs/libical-0.46:= )
+ eds? ( >=gnome-extra/evolution-data-server-3.6.0:= )
+ goffice? ( >=x11-libs/goffice-0.10.2:0.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.0.0:= )
+ map? ( >=media-libs/libchamplain-0.12:0.12 )
+ plugins? (
+ collab? (
+ >=dev-libs/libxml2-2.4:2
+ >=net-libs/loudmouth-1
+ net-libs/libsoup:2.4
+ net-libs/gnutls:= )
+ grammar? ( >=dev-libs/link-grammar-4.2.1 )
+ math? ( >=x11-libs/gtkmathview-0.7.5 )
+ ots? ( >=app-text/ots-0.5-r1 )
+ readline? ( sys-libs/readline:0= )
+ thesaurus? ( >=app-text/aiksaurus-1.2[gtk] )
+ wordperfect? (
+ app-text/libwpd:0.10
+ app-text/libwpg:0.3 )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ )
+ redland? (
+ >=dev-libs/redland-1.0.10
+ >=dev-libs/rasqal-0.9.17 )
+ spell? ( >=app-text/enchant-1.2 )
+ !<app-office/abiword-plugins-2.8
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-libs/boost-1.40.0
+ virtual/pkgconfig
+ collab? ( dev-cpp/asio )
+"
+
+PATCHES=(
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13842
+ "${FILESDIR}"/${PN}-2.8.3-desktop.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13843
+ "${FILESDIR}"/${PN}-2.6.0-boolean.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13844
+ "${FILESDIR}"/${PN}-3.0.0-librevenge.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13845
+ "${FILESDIR}"/${PN}-3.0.0-link-grammar-5-second.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13846
+ "${FILESDIR}"/${PN}-3.0.0-libwp.patch
+ "${FILESDIR}"/${PN}-3.0.1-libwps-0.4.patch
+ "${FILESDIR}"/${PN}-3.0.1-fixwps.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13847
+ "${FILESDIR}"/${PN}-3.0.2-fix-installing-readme.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13841
+ "${FILESDIR}"/${PN}-3.0.2-fix-nullptr-c++98.patch
+
+ # http://bugzilla.abisource.com/show_bug.cgi?id=13815
+ "${FILESDIR}"/${PN}-3.0.2-fix-black-drawing-regression.patch
+)
+
+src_configure() {
+ local plugins=()
+
+ if use plugins; then
+ # Plugins depending on libgsf
+ plugins=(t602 docbook clarisworks wml kword hancom openwriter pdf
+ loadbindings mswrite garble pdb applix opendocument sdw xslfo)
+
+ # Plugins depending on librsvg
+ plugins+=(svg)
+
+ # Plugins not depending on anything
+ plugins+=(gimp bmp freetranslation iscii s5 babelfish opml eml wikipedia
+ gdict passepartout google presentation urldict hrtext mif openxml)
+
+ # inter7eps: eps.h
+ # libtidy: gsf + tidy.h
+ # paint: windows only ?
+ use collab && plugins+=(collab)
+ use goffice && plugins+=(goffice)
+ use latex && plugins+=(latex)
+ use math && plugins+=(mathview)
+ use ots && plugins+=(ots)
+ # psion: >=psiconv-0.9.4
+ use readline && plugins+=(command)
+ use thesaurus && plugins+=(aiksaurus)
+ use wmf && plugins+=(wmf)
+ # wordperfect: >=wpd-0.9 >=wpg-0.2
+ use wordperfect && plugins+=(wpg)
+ fi
+
+ gnome2_src_configure \
+ --enable-plugins="${plugins[*]}" \
+ --disable-static \
+ --disable-default-plugins \
+ --disable-builtin-plugins \
+ --disable-collab-backend-telepathy \
+ --enable-clipart \
+ --enable-statusbar \
+ --enable-templates \
+ --with-gio \
+ --without-gnomevfs \
+ --without-gtk2 \
+ $(use_enable debug) \
+ $(use_with goffice goffice) \
+ $(use_with calendar libical) \
+ $(use_enable cups print) \
+ $(use_enable collab collab-backend-xmpp) \
+ $(use_enable collab collab-backend-tcp) \
+ $(use_enable collab collab-backend-service) \
+ $(use_with eds evolution-data-server) \
+ $(use_enable introspection) \
+ $(use_with map champlain) \
+ $(use_with redland) \
+ $(use_enable spell)
+}