summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-03-28 17:39:40 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-03-28 17:46:19 -0400
commit7a445dde57a57fd7eecd4ddf7939c541f2bba085 (patch)
tree472a8898396ec872e2657962aacce92e9163903a /app-office/gnucash/files
parentapp-doc/gnucash-docs: Bump to 3.8b (diff)
downloadgentoo-7a445dde57a57fd7eecd4ddf7939c541f2bba085.tar.gz
gentoo-7a445dde57a57fd7eecd4ddf7939c541f2bba085.tar.bz2
gentoo-7a445dde57a57fd7eecd4ddf7939c541f2bba085.zip
app-office/gnucash: Bump to 3.8b
Bump to EAPI 7. Switch to ninja to run tests instead of GNU make. Install example files into their own directory. No longer install redundant license file. This also prevents a sandbox violation. Because net-libs/aqbanking dropped the gtk USE flag, we've increased the version requirement, and trigger the gtk USE flag on sys-libs/gwenhywfar directly. Also, make the >dev-libs/libofx dependent on the subslot as well. Bug: https://bugs.gentoo.org/714920 Bug: https://bugs.gentoo.org/704632 Bug: https://bugs.gentoo.org/692626 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'app-office/gnucash/files')
-rw-r--r--app-office/gnucash/files/gnucash-3.8-examples-subdir.patch10
-rw-r--r--app-office/gnucash/files/gnucash-3.8-exclude-license.patch32
2 files changed, 42 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch b/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch
new file mode 100644
index 000000000000..b271be896c03
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.8-examples-subdir.patch
@@ -0,0 +1,10 @@
+--- a/doc/examples/CMakeLists.txt
++++ b/doc/examples/CMakeLists.txt
+@@ -21,6 +21,6 @@
+ web.qif
+ )
+
+-install(FILES ${examples_DATA} DESTINATION ${CMAKE_INSTALL_DOCDIR})
++install(FILES ${examples_DATA} DESTINATION ${CMAKE_INSTALL_DOCDIR}/examples)
+
+ set_dist_list(examples_DIST ${examples_DATA} CMakeLists.txt )
diff --git a/app-office/gnucash/files/gnucash-3.8-exclude-license.patch b/app-office/gnucash/files/gnucash-3.8-exclude-license.patch
new file mode 100644
index 000000000000..553fb2a10f86
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.8-exclude-license.patch
@@ -0,0 +1,32 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -660,7 +660,6 @@
+ ChangeLog.2018
+ DOCUMENTERS
+ HACKING
+- LICENSE
+ NEWS
+ README.dependencies
+ )
+@@ -932,21 +931,6 @@
+ )
+ endif()
+
+-#Link LICENSE to COPYING so that people expecting to find it,
+-#will. COPYING is normally linked by autogen.sh to the latest
+-#automake-provided version.
+-set (_CMD create_symlink)
+-if (WIN32)
+- set(_CMD copy)
+-endif()
+-
+-install(CODE
+-" execute_process(
+- COMMAND ${CMAKE_COMMAND} -E ${_CMD} LICENSE COPYING
+- WORKING_DIRECTORY ${CMAKE_INSTALL_DOCDIR}
+- )"
+-)
+-
+ #For windows, copy in some DLLs from Mingw
+
+ if (WIN32)