summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2019-09-15 15:58:05 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-13 13:40:24 +0200
commitff46a76b91b203f21ddc917a6486be6d2f73011d (patch)
tree68368b027cb6c59e21ddad6ef3db439c392b85c5 /app-office/gnucash/files
parentapp-office/gnucash: Bump gnucash-3.7 (diff)
downloadgentoo-ff46a76b91b203f21ddc917a6486be6d2f73011d.tar.gz
gentoo-ff46a76b91b203f21ddc917a6486be6d2f73011d.tar.bz2
gentoo-ff46a76b91b203f21ddc917a6486be6d2f73011d.zip
app-office/gnucash: Fix check_symbol_exists error
Adds "include(CheckSymbolExists)" to avoid the error "Unknown CMake command check_symbol_exists" Closes: https://bugs.gentoo.org/690270 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/gnucash/files')
-rw-r--r--app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch b/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch
new file mode 100644
index 000000000000..c0e1778164cd
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-3.7-include-checksymbolexists.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/690270
+
+--- a/gnucash/register/register-gnome/CMakeLists.txt
++++ b/gnucash/register/register-gnome/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ add_subdirectory(test)
+
++include(CheckSymbolExists)
++
+ #GTK before 3.14 didn't have GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK
+ check_symbol_exists(GDK_MODIFIER_INTENT_DEFAULT_MOD_MASK gdk/gdktypes.h have_mod_mask)
+ if (NOT have_mod_mask)