summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-26 14:51:48 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-26 15:20:26 +0100
commitd156a6deb35e8cc56c6ae5624f85924fbf018b47 (patch)
tree1cd5c6ebd1aa312893f4165d3eb1dae94e814e84 /app-office/gnumeric
parentapp-office/gnumeric: Drop old (diff)
downloadgentoo-d156a6deb35e8cc56c6ae5624f85924fbf018b47.tar.gz
gentoo-d156a6deb35e8cc56c6ae5624f85924fbf018b47.tar.bz2
gentoo-d156a6deb35e8cc56c6ae5624f85924fbf018b47.zip
app-office/gnumeric: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.25.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index b8ae41011250..a6bd3058d5b5 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.24.tar.xz 18526768 SHA256 c59d5271b27366008bccb4d53ad8333da36d837003a018892f2da325c1449551 SHA512 71bed41a1b50ed57e9ab4993df8d963cb14a9f6f3fbf87d81c30f71359a23c4092daab00079936e587a118041a303c1c563bcd3f38f2aaea78a9ae5593dcdd4b WHIRLPOOL 648930de4d37d25db471fe9b639b91a64a1d1ebf1a50291ef2c79a23d4082b7249e6197467e86ce752e96699b38a7c3d86730cead7d0438c7e6605521b61e7b8
+DIST gnumeric-1.12.25.tar.xz 18536284 SHA256 9709a8fccfc371a07b1590d037a43e525531d5a46f31c5c5fe223c6054cecdb6 SHA512 260d08391b336437df7f9160ca7ceaf123f2ae84afaea81e7be3b52a3999d40b03b5292ed14a7682d4376c90ef3d69ae12a4767cf1a8fb75761e66ee1e801684 WHIRLPOOL 1f245120c2dac7cd10283597e3364d7937e646f07438f20f52af4f536ca26a1594371851316163f20dd75c0bc1047058a055edecf451b710fde459b241bcc6ef
diff --git a/app-office/gnumeric/gnumeric-1.12.25.ebuild b/app-office/gnumeric/gnumeric-1.12.25.ebuild
new file mode 100644
index 000000000000..a78dd0792a06
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.25.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 flag-o-matic python-single-r1
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+introspection libgda perl python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.38.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.22:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}] )
+ libgda? ( gnome-extra/libgda:5[gtk] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl) \
+ $(use_with python)
+}