summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2019-02-05 10:10:57 -0700
committerDenis Dupeyron <calchan@gentoo.org>2019-02-05 10:10:57 -0700
commit18191eb875669ef71394cf0b8289080ae1b408e2 (patch)
tree61ec477894bb1322a76b782068d950af444aec58 /app-office/homebank/homebank-5.2.2.ebuild
parentapp-misc/note: EAPI bump, fix deps, general cleanup (diff)
downloadgentoo-18191eb875669ef71394cf0b8289080ae1b408e2.tar.gz
gentoo-18191eb875669ef71394cf0b8289080ae1b408e2.tar.bz2
gentoo-18191eb875669ef71394cf0b8289080ae1b408e2.zip
app-office/homebank: bump to 5.2.2 (bug #668878)
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'app-office/homebank/homebank-5.2.2.ebuild')
-rw-r--r--app-office/homebank/homebank-5.2.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-office/homebank/homebank-5.2.2.ebuild b/app-office/homebank/homebank-5.2.2.ebuild
new file mode 100644
index 000000000000..17236ea7d31d
--- /dev/null
+++ b/app-office/homebank/homebank-5.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg-utils gnome2-utils
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.39
+ >=net-libs/libsoup-2.26
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}