summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/kmymoney/kmymoney-4.7.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/kmymoney/kmymoney-4.7.2.ebuild')
-rw-r--r--app-office/kmymoney/kmymoney-4.7.2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-office/kmymoney/kmymoney-4.7.2.ebuild b/app-office/kmymoney/kmymoney-4.7.2.ebuild
new file mode 100644
index 000000000000..5d43287ed8a0
--- /dev/null
+++ b/app-office/kmymoney/kmymoney-4.7.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr gl
+hu it kk nds nl pl pt pt_BR ro ru sk sv tr uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit kde4-base
+
+DESCRIPTION="Personal finance manager for KDE"
+HOMEPAGE="http://kmymoney2.sourceforge.net/"
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug calendar doc hbci ofx quotes"
+
+COMMON_DEPEND="
+ app-crypt/gpgme
+ >=app-office/libalkimia-4.3.2
+ dev-libs/gmp:0
+ dev-libs/libgpg-error
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ calendar? ( dev-libs/libical:= )
+ hbci? (
+ >=net-libs/aqbanking-5.0.1
+ >=sys-libs/gwenhywfar-4.0.1[qt4]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ quotes? ( dev-perl/Finance-Quote )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_DESIGNER=OFF
+ $(cmake-utils_use_enable calendar LIBICAL)
+ $(cmake-utils_use_use doc DEVELOPER_DOC)
+ $(cmake-utils_use_enable hbci KBANKING)
+ $(cmake-utils_use_enable ofx LIBOFX)
+ )
+ kde4-base_src_configure
+}
+
+src_compile() {
+ kde4-base_src_compile
+
+ use doc && kde4-base_src_compile apidoc
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}/apidocs/html/")
+ kde4-base_src_install
+}