summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/kraft
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/kraft')
-rw-r--r--app-office/kraft/Manifest2
-rw-r--r--app-office/kraft/kraft-0.57.ebuild29
-rw-r--r--app-office/kraft/kraft-0.58.ebuild29
-rw-r--r--app-office/kraft/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/app-office/kraft/Manifest b/app-office/kraft/Manifest
new file mode 100644
index 000000000000..a23f5f87bd9e
--- /dev/null
+++ b/app-office/kraft/Manifest
@@ -0,0 +1,2 @@
+DIST kraft-0.57.tar.xz 550736 SHA256 4e8ad3b0db57dd03b10db3d4df4a89a3bcdd95beecc23adec352b517fffff63c SHA512 56f5fd6aa0c369e9baad5b7df5d74b1f14a6810cf976757d031702ea29565b0bb5630c172d0ead2bbcc3e39afd402fc15f8ceb079615cc61c9ff547703330438 WHIRLPOOL 74e8bce1027a4ed767a2bb67dd6f7ac27f561671ac9f157d91ccd69dca5a2f1b3890af8c92db4c1696883079d662ab8ed3f22496fe8fd2104bcbefa63b44a2d1
+DIST kraft-0.58.tar.xz 556404 SHA256 12c92dbdae05d01a491111ed42dfa6f487ec477f60e536e5a80efa6592997524 SHA512 450d68022f5ea1a19b6b9461f3db65233cdc6939cae5367a4c95d22eb6207881cbd798d723a87d43d3f20e84d8ffb2d601a3245324fa1c10078300c5b8e06845 WHIRLPOOL 60371a2db0bc6b39d3c6ce0f20922e8749df3ae74bcafb7a43c5861b9715dff7aef8407f2446702394bf697dca647e3d61989fa733e0b40514e493ecd25f93ca
diff --git a/app-office/kraft/kraft-0.57.ebuild b/app-office/kraft/kraft-0.57.ebuild
new file mode 100644
index 000000000000..526a8146d122
--- /dev/null
+++ b/app-office/kraft/kraft-0.57.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs cs da de en_GB eo es et fi fr ga gl hu it ja lt mai mr nds
+nl pl pt pt_BR ru sk sv tr ug uk zh_CN"
+inherit kde4-base
+
+DESCRIPTION="Software for operating a small business, helping create documents such as offers and invoices"
+HOMEPAGE="http://www.volle-kraft-voraus.de/"
+SRC_URI="mirror://sourceforge/kraft/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ dev-cpp/ctemplate
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[mysql,sqlite]
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS Changes.txt README Releasenotes.txt TODO )
diff --git a/app-office/kraft/kraft-0.58.ebuild b/app-office/kraft/kraft-0.58.ebuild
new file mode 100644
index 000000000000..39be85def576
--- /dev/null
+++ b/app-office/kraft/kraft-0.58.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="ast bg bs cs da de en_GB eo es et fi fr ga gl hu it ja lt mai mr nds
+nl pl pt pt_BR ru sk sv tr ug uk zh_CN"
+inherit kde4-base
+
+DESCRIPTION="Software for operating a small business, helping create documents such as offers and invoices"
+HOMEPAGE="http://www.volle-kraft-voraus.de/"
+SRC_URI="mirror://sourceforge/kraft/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-cpp/ctemplate
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4[mysql,sqlite]
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS Changes.txt README Releasenotes.txt TODO )
diff --git a/app-office/kraft/metadata.xml b/app-office/kraft/metadata.xml
new file mode 100644
index 000000000000..218d86983c07
--- /dev/null
+++ b/app-office/kraft/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">kraft</remote-id>
+ </upstream>
+</pkgmetadata>