summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-02-12 22:05:14 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2019-02-13 13:16:25 -0800
commitae37ec6c11209ed8057143618cddf9f210e01a22 (patch)
tree7d7fd38773b60ac034dc7514921c1b70c6ea89cd /app-office/ledger
parentnet-proxy/tayga: add init script (diff)
downloadgentoo-ae37ec6c11209ed8057143618cddf9f210e01a22.tar.gz
gentoo-ae37ec6c11209ed8057143618cddf9f210e01a22.tar.bz2
gentoo-ae37ec6c11209ed8057143618cddf9f210e01a22.zip
app-office/ledger: bump
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-office/ledger')
-rw-r--r--app-office/ledger/Manifest1
-rw-r--r--app-office/ledger/ledger-3.1.2.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-office/ledger/Manifest b/app-office/ledger/Manifest
index dfd3c2ecfdfd..6538340a9b05 100644
--- a/app-office/ledger/Manifest
+++ b/app-office/ledger/Manifest
@@ -1,2 +1,3 @@
DIST de1b48a013b6f4bdf68f7edf333db63a0994ef20.patch 4533 BLAKE2B 39a2ef3b9e6a8e495837376c8a36c9276fbf58bd4ff45a07926e71ca40d65ddb5761e107752247fa2986e63d454e6461bdf0a3bc7bc773db97dcd3027091a841 SHA512 019c862fecb3f3a0682c2f1237ecebec40eafae0b38d6b5d8e56f9829155353569f889dac468ff5b1b2e23f15ae9fe538a0b027f628776f27ea818c12fd1d0b2
DIST ledger-3.1.1.tar.gz 842364 BLAKE2B 83f9008f6daf4da39ece192388e0231719bc7297d2a911f1209662f57d2963b9ea09a5b6de9450ed29c5973efa47d9d6a250e052c155d9ba742cdb3ee075f341 SHA512 3f81b98a414cdfc0e272de4e958770149fb1acc8bda880d270e1459ce35294a220c52820bb9af49a751ac3a80b878f81fc7799ba41e0a1be43eba72081351bf5
+DIST ledger-3.1.2.tar.gz 801112 BLAKE2B 71b907a83fe10857d17de746c0d124572859c9eca237130ebbfa5b730406470a5d31025736e80516feaac7daf14a4edb8b644ed72a0827f9714ac9cb2b79c0fb SHA512 445d9a9c70aa3e59718f8fb75e4110c73f2f476436149fdd456b5fe7b9cee9333c09647080049989599dfac491e5bdd0d143717e58e15989db0fcaad4e5a958d
diff --git a/app-office/ledger/ledger-3.1.2.ebuild b/app-office/ledger/ledger-3.1.2.ebuild
new file mode 100644
index 000000000000..1fe3082e204b
--- /dev/null
+++ b/app-office/ledger/ledger-3.1.2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit check-reqs cmake-utils elisp-common python-single-r1
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="https://www.ledger-cli.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc emacs python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+SITEFILE=50${PN}-gentoo-${PV}.el
+
+CHECKREQS_MEMORY=8G
+
+RDEPEND="
+ dev-libs/boost:=[python?]
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ emacs? ( virtual/emacs )
+ python? (
+ dev-libs/boost:=[${PYTHON_USEDEP}]
+ dev-python/cheetah
+ ${PYTHON_DEPS}
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/utfcpp
+ doc? (
+ sys-apps/texinfo
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )
+"
+
+PATCHES=()
+
+# Building with python integration seems to fail without 8G available
+# RAM(!) Since the memory check in check-reqs doesn't count swap, it
+# may be unfair to fail the build entirely on the memory test alone.
+# Therefore check-reqs_pkg_pretend is deliberately omitted so that we
+# ewarn but not eerror.
+pkg_pretend() {
+ :
+}
+
+pkg_setup() {
+ if use python; then
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -r -i \
+ -e '/set.BOOST_PYTHON/s/python27/python-2.7/g' \
+ "${S}/CMakeLists.txt" \
+ || die "Failed to update CMakeLists.txt for python2.7 boost"
+
+ # Want to type "info ledger" not "info ledger3"
+ sed -i -e 's/ledger3/ledger/g' \
+ doc/ledger3.texi \
+ doc/CMakeLists.txt \
+ test/CheckTexinfo.py \
+ tools/cleanup.sh \
+ tools/gendocs.sh \
+ tools/prepare-commit-msg \
+ tools/spellcheck.sh \
+ || die "Failed to update info file name in file contents"
+
+ mv doc/ledger{3,}.texi || die "Failed to rename info file name"
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EMACSLISP="$(usex emacs)"
+ -DBUILD_DOCS="$(usex doc)"
+ -DBUILD_WEB_DOCS="$(usex doc)"
+ -DUSE_PYTHON="$(usex python)"
+ -DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON
+ -DBUILD_DEBUG="$(usex debug)"
+ -DUSE_PYTHON27_COMPONENT=yes
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ einfo
+ einfo "Since version 3, vim support is released separately."
+ einfo "See https://github.com/ledger/vim-ledger"
+ einfo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
+# rainy day TODO:
+# - IUSE test